summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <kraj@juniper.net>2012-07-09 19:13:43 -0700
committerKhem Raj <raj.khem@gmail.com>2012-07-09 19:20:20 -0700
commit5042d7e2282cc8ef88ef8976a53446bcb5fef37a (patch)
tree0267a32b03ecc1431ccc3f94a55db6aa1741e4c0
parentd599b67e344862e9e030509657ea58f45db66938 (diff)
downloadmeta-fsl-ppc-5042d7e2282cc8ef88ef8976a53446bcb5fef37a.tar.gz
linux-qoriq-sdk: Update to latest 1.2 SDK release
Signed-off-by: Khem Raj <kraj@juniper.net>
-rw-r--r--recipes-kernel/linux/files/0001-compiler.h-Undef-before-redefining-__attribute_const.patch31
-rw-r--r--recipes-kernel/linux/files/add-no-error-array-bounds.patch13
-rw-r--r--recipes-kernel/linux/files/add-no-unused-but-set-variable.patch13
-rw-r--r--recipes-kernel/linux/linux-qoriq-sdk.inc7
4 files changed, 2 insertions, 62 deletions
diff --git a/recipes-kernel/linux/files/0001-compiler.h-Undef-before-redefining-__attribute_const.patch b/recipes-kernel/linux/files/0001-compiler.h-Undef-before-redefining-__attribute_const.patch
deleted file mode 100644
index bf2f6e7..0000000
--- a/recipes-kernel/linux/files/0001-compiler.h-Undef-before-redefining-__attribute_const.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 6f92ab6de9d8daeb575949bbbcbc7bcdcebc60af Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 5 Jan 2012 11:42:35 -0800
4Subject: [PATCH] compiler.h: Undef before redefining __attribute_const__
5
6This is required to avoid warnings like
7util/include/linux/compiler.h:8:0: error: "__attribute_const__" redefined [-Werror]
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10
11Upstream-Status: Pending
12
13---
14 tools/perf/util/include/linux/compiler.h | 4 +++-
15 1 files changed, 3 insertions(+), 1 deletions(-)
16
17--- a/tools/perf/util/include/linux/compiler.h
18+++ b/tools/perf/util/include/linux/compiler.h
19@@ -4,9 +4,11 @@
20 #ifndef __always_inline
21 #define __always_inline inline
22 #endif
23+#undef __user
24 #define __user
25+#undef __attribute_const__
26 #define __attribute_const__
27-
28+#undef __used
29 #define __used __attribute__((__unused__))
30
31 #endif
diff --git a/recipes-kernel/linux/files/add-no-error-array-bounds.patch b/recipes-kernel/linux/files/add-no-error-array-bounds.patch
deleted file mode 100644
index 57b3974..0000000
--- a/recipes-kernel/linux/files/add-no-error-array-bounds.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1Index: git/Makefile
2===================================================================
3--- git.orig/Makefile
4+++ git/Makefile
5@@ -558,7 +558,7 @@ endif # $(dot-config)
6 # Defaults to vmlinux, but the arch makefile usually adds further targets
7 all: vmlinux
8
9-KBUILD_CFLAGS += -Wno-unused-but-set-variable
10+KBUILD_CFLAGS += -Wno-unused-but-set-variable -Wno-error=array-bounds
11
12 ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
13 KBUILD_CFLAGS += -Os
diff --git a/recipes-kernel/linux/files/add-no-unused-but-set-variable.patch b/recipes-kernel/linux/files/add-no-unused-but-set-variable.patch
deleted file mode 100644
index 5133529..0000000
--- a/recipes-kernel/linux/files/add-no-unused-but-set-variable.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1diff --git a/Makefile b/Makefile
2index e821f72..cb2fcba 100644
3--- a/Makefile
4+++ b/Makefile
5@@ -526,6 +526,8 @@ endif # $(dot-config)
6 # Defaults vmlinux but it is usually overridden in the arch makefile
7 all: vmlinux
8
9+KBUILD_CFLAGS += -Wno-unused-but-set-variable
10+
11 ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
12 KBUILD_CFLAGS += -Os
13 else
diff --git a/recipes-kernel/linux/linux-qoriq-sdk.inc b/recipes-kernel/linux/linux-qoriq-sdk.inc
index 7e5dbf4..4b6505e 100644
--- a/recipes-kernel/linux/linux-qoriq-sdk.inc
+++ b/recipes-kernel/linux/linux-qoriq-sdk.inc
@@ -1,13 +1,10 @@
1LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" 1LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
2 2
3PV = "3.0.6" 3PV = "3.0.34"
4PR = "r3" 4PR = "r3"
5 5
6SRCREV = "1e3e8ed15249d73a066ddfe2e80882935c35dcb7" 6SRCREV = "fsl-sdk-v1.2"
7SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git \ 7SRC_URI = "git://git.freescale.com/ppc/sdk/linux.git \
8 file://add-no-unused-but-set-variable.patch \
9 file://add-no-error-array-bounds.patch \
10 file://0001-compiler.h-Undef-before-redefining-__attribute_const.patch \
11 " 8 "
12 9
13KSRC ?= "" 10KSRC ?= ""