summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2012-07-23 14:53:49 -0700
committerKhem Raj <raj.khem@gmail.com>2012-07-23 14:54:24 -0700
commit42e8ca202c8003cad0e8b7b61ec10269319acc0f (patch)
treed83263478ea06c6a2bbe4128e89fc72afa5143ad
parent34e1f35c7744a1ef2abd5b50d932461b6e4bbb74 (diff)
downloadmeta-fsl-ppc-42e8ca202c8003cad0e8b7b61ec10269319acc0f.tar.gz
linux-qoriq-sdk-headers: Make it machine independent
The linux libc headers should not be dependent on machine at all. These are generic enough that we can use an all purpose defconfig. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-kernel/linux/linux-qoriq-sdk-headers.bb41
1 files changed, 12 insertions, 29 deletions
diff --git a/recipes-kernel/linux/linux-qoriq-sdk-headers.bb b/recipes-kernel/linux/linux-qoriq-sdk-headers.bb
index 4be6c42..b1cbb8d 100644
--- a/recipes-kernel/linux/linux-qoriq-sdk-headers.bb
+++ b/recipes-kernel/linux/linux-qoriq-sdk-headers.bb
@@ -2,46 +2,29 @@ DESCRIPTION = "Linux kernel headers for Freescale platforms"
2SECTION = "devel" 2SECTION = "devel"
3LICENSE = "GPLv2" 3LICENSE = "GPLv2"
4 4
5PKGSUFFIX = ""
6PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
7
8INHIBIT_DEFAULT_DEPS = "1" 5INHIBIT_DEFAULT_DEPS = "1"
9PROVIDES = "linux-libc-headers${PKGSUFFIX} ${PN}" 6PROVIDES = "linux-libc-headers ${PN}"
10RPROVIDES_${PN}-dev += "linux-libc-headers${PKGSUFFIX}-dev" 7RPROVIDES_${PN}-dev += "linux-libc-headers-dev"
11RPROVIDES_${PN}-dbg += "linux-libc-headers${PKGSUFFIX}-dbg" 8RPROVIDES_${PN}-dbg += "linux-libc-headers-dbg"
12RDEPENDS_${PN}-dev = "" 9RDEPENDS_${PN}-dev = ""
13RRECOMMENDS_${PN}-dbg = "linux-libc-headers${PKGSUFFIX}-dev (= ${EXTENDPKGV})" 10RRECOMMENDS_${PN}-dbg = "linux-libc-headers-dev (= ${EXTENDPKGV})"
14 11
15require recipes-kernel/linux/linux-qoriq-sdk.inc 12require recipes-kernel/linux/linux-qoriq-sdk.inc
16 13
17set_arch() { 14inherit kernel-arch
18 case ${TARGET_ARCH} in
19 arm*) ARCH=arm ;;
20 i*86*) ARCH=i386 ;;
21 ia64*) ARCH=ia64 ;;
22 mips*) ARCH=mips ;;
23 powerpc*) ARCH=powerpc ;;
24 x86_64*) ARCH=x86_64 ;;
25 esac
26}
27 15
28do_configure () { 16do_configure() {
29 set_arch 17 oe_runmake allnoconfig
30 cp ${KERNEL_DEFCONFIG} ${B}/.config
31 oe_runmake oldconfig ARCH=${ARCH}
32} 18}
33do_configure[vardepsexclude] += "KERNEL_DEFCONFIG"
34 19
35do_compile () { 20do_compile () {
36} 21}
37 22
38do_install() { 23do_install() {
39 set_arch 24 oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix}
40 cd ${S} 25 # Kernel should not be exporting this header
41 oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=${ARCH} 26 rm -f ${D}${exec_prefix}/include/scsi/scsi.h
42 27
43 # The ..install.cmd conflicts between various configure runs 28 # The ..install.cmd conflicts between various configure runs
44 find ${D}${includedir} -name ..install.cmd | xargs rm -f 29 find ${D}${includedir} -name ..install.cmd | xargs rm -f
45} 30}
46
47BBCLASSEXTEND = "nativesdk"