summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <b40290@freescale.com>2012-04-18 14:19:29 +0000
committerZhenhua Luo <b19537@freescale.com>2012-04-23 09:53:25 +0800
commit077ee6adccae12920855d8f2e8b28990c99cb49e (patch)
tree43df84ce7294d6c4dc2562901216ee82c06f8f68
parentff4ccfcb48acf6962e3c599e358b08929b0493ec (diff)
downloadmeta-fsl-ppc-077ee6adccae12920855d8f2e8b28990c99cb49e.tar.gz
recipes-append/udev: add skip rules for inappropriate block devices
Signed-off-by: Chunrong Guo <b40290@freescale.com>
-rw-r--r--recipes-append/udev/files/local.rules39
-rw-r--r--recipes-append/udev/udev_164.bbappend4
2 files changed, 43 insertions, 0 deletions
diff --git a/recipes-append/udev/files/local.rules b/recipes-append/udev/files/local.rules
new file mode 100644
index 0000000..9c134ef
--- /dev/null
+++ b/recipes-append/udev/files/local.rules
@@ -0,0 +1,39 @@
1# There are a number of modifiers that are allowed to be used in some
2# of the different fields. They provide the following subsitutions:
3#
4# %n the "kernel number" of the device.
5# For example, 'sda3' has a "kernel number" of '3'
6# %e the smallest number for that name which does not matches an existing node
7# %k the kernel name for the device
8# %M the kernel major number for the device
9# %m the kernel minor number for the device
10# %b the bus id for the device
11# %c the string returned by the PROGRAM
12# %s{filename} the content of a sysfs attribute
13# %% the '%' char itself
14#
15
16KERNEL=="nbd*", GOTO="persistent_storage_end"
17
18# Media automounting
19SUBSYSTEM=="block", ACTION=="add" RUN+="/etc/udev/scripts/mount.sh"
20SUBSYSTEM=="block", ACTION=="remove" RUN+="/etc/udev/scripts/mount.sh"
21
22# Handle network interface setup
23SUBSYSTEM=="net", ACTION=="add" RUN+="/etc/udev/scripts/network.sh"
24SUBSYSTEM=="net", ACTION=="remove" RUN+="/etc/udev/scripts/network.sh"
25
26# The first framebuffer is symlinked to /dev/fb
27KERNEL=="fb0", SYMLINK+="fb"
28
29# The first rtc device is symlinked to /dev/rtc
30KERNEL=="rtc0", SYMLINK+="rtc"
31
32# Try and modprobe for drivers for new hardware
33ACTION=="add", DEVPATH=="/devices/*", ENV{MODALIAS}=="?*", RUN+="/sbin/modprobe $env{MODALIAS}"
34
35# Create a symlink to any touchscreen input device
36SUBSYSTEM=="input", KERNEL=="event[0-9]*", ATTRS{modalias}=="input:*-e0*,3,*a0,1,*18,*", SYMLINK+="input/touchscreen0"
37
38LABEL="persistent_storage_end"
39
diff --git a/recipes-append/udev/udev_164.bbappend b/recipes-append/udev/udev_164.bbappend
new file mode 100644
index 0000000..7277e47
--- /dev/null
+++ b/recipes-append/udev/udev_164.bbappend
@@ -0,0 +1,4 @@
1FILEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3PR .= "+${DISTRO}.0"
4