diff options
Diffstat (limited to 'recipes-multimedia')
5 files changed, 61 insertions, 77 deletions
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin.inc b/recipes-multimedia/gst-plugins/gst-fsl-plugin.inc index 1425445..e179c76 100644 --- a/recipes-multimedia/gst-plugins/gst-fsl-plugin.inc +++ b/recipes-multimedia/gst-plugins/gst-fsl-plugin.inc | |||
@@ -7,7 +7,8 @@ SECTION = "multimedia" | |||
7 | 7 | ||
8 | DEPENDS = "gstreamer gst-plugins-base libfslcodec libfslparser virtual/kernel" | 8 | DEPENDS = "gstreamer gst-plugins-base libfslcodec libfslparser virtual/kernel" |
9 | DEPENDS_append_mx5 = " imx-lib imx-vpu" | 9 | DEPENDS_append_mx5 = " imx-lib imx-vpu" |
10 | DEPENDS_append_mx6 = " imx-lib libfslvpuwrap" | 10 | DEPENDS_append_mx6 = " imx-lib imx-vpu libfslvpuwrap" |
11 | DEPENDS_append_mx6sl = " imx-lib" | ||
11 | 12 | ||
12 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ | 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ |
13 | file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ | 14 | file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \ |
@@ -21,12 +22,13 @@ inherit autotools pkgconfig | |||
21 | 22 | ||
22 | PLATFORM_mx5 = "MX51" | 23 | PLATFORM_mx5 = "MX51" |
23 | PLATFORM_mx6 = "MX6" | 24 | PLATFORM_mx6 = "MX6" |
25 | PLATFORM_mx6sl = "MX6SL" | ||
24 | PLATFORM_mx28 = "MX28" | 26 | PLATFORM_mx28 = "MX28" |
25 | 27 | ||
26 | # Todo add a mechanism to map posible build targets | 28 | # Todo add a mechanism to map posible build targets |
27 | INCLUDE_DIR = "-I${STAGING_KERNEL_DIR}/include" | 29 | INCLUDE_DIR = "-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" |
28 | EXTRA_OEMAKE = "INCLUDES=${INCLUDE_DIR}" | 30 | EXTRA_OEMAKE = "INCLUDES="${INCLUDE_DIR}"" |
29 | EXTRA_OECONF = "PLATFORM=${PLATFORM} --disable-valgrind --disable-examples --disable-debug" | 31 | EXTRA_OECONF = "PLATFORM=${PLATFORM} --disable-valgrind --disable-examples --disable-debug CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR}" |
30 | CACHED_CONFIGUREVARS += "CROSS_ROOT=${STAGING_DIR_TARGET}" | 32 | CACHED_CONFIGUREVARS += "CROSS_ROOT=${STAGING_DIR_TARGET}" |
31 | 33 | ||
32 | PACKAGES += "${PN}-libmfwsconf ${PN}-libgplaycore ${PN}-libgstfsl \ | 34 | PACKAGES += "${PN}-libmfwsconf ${PN}-libgplaycore ${PN}-libgstfsl \ |
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin/configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch b/recipes-multimedia/gst-plugins/gst-fsl-plugin/configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch deleted file mode 100644 index cab9ff4..0000000 --- a/recipes-multimedia/gst-plugins/gst-fsl-plugin/configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch +++ /dev/null | |||
@@ -1,58 +0,0 @@ | |||
1 | From 6f75a9f4ad108c1f4a3dff4dd08def174ab83a69 Mon Sep 17 00:00:00 2001 | ||
2 | From: Otavio Salvador <otavio@ossystems.com.br> | ||
3 | Date: Tue, 21 May 2013 16:43:31 -0300 | ||
4 | Subject: [PATCH] configure.ac: Use pkg-config sysroot when checking for soname | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> | ||
9 | --- | ||
10 | configure.ac | 12 +++++------- | ||
11 | 1 file changed, 5 insertions(+), 7 deletions(-) | ||
12 | |||
13 | diff --git a/configure.ac b/configure.ac | ||
14 | index e4cdb86..c12ceb4 100755 | ||
15 | --- a/configure.ac | ||
16 | +++ b/configure.ac | ||
17 | @@ -16,7 +16,7 @@ AC_DEFUN([FIND_PARSER_SONAME], | ||
18 | [ | ||
19 | AC_MSG_CHECKING([for lib_$1_parser_$2_elinux.3.0.so soname]) | ||
20 | path=`$PKG_CONFIG --variable=libdir libfslparser` | ||
21 | - SONAME=$( $CC -print-file-name=$path/lib_$1_parser_$2_elinux.so | \ | ||
22 | + SONAME=$( $CC -print-file-name=$PKG_CONFIG_SYSROOT_DIR$path/lib_$1_parser_$2_elinux.so | \ | ||
23 | while read output; do objdump -p $output | \ | ||
24 | grep "SONAME" | \ | ||
25 | sed -e 's/ \+SONAME \+//'; done 2> /dev/null ) | ||
26 | @@ -27,16 +27,15 @@ AC_DEFUN([FIND_PARSER_SONAME], | ||
27 | else | ||
28 | AC_MSG_RESULT([$SONAME]) | ||
29 | fi | ||
30 | - apath=`echo $path | sed -e 's|.*/imx-mm/|/usr/lib/imx-mm/|'` | ||
31 | - $1_$2_SONAME=$apath/$SONAME | ||
32 | + $1_$2_SONAME=$path/$SONAME | ||
33 | AC_SUBST($1_$2_SONAME) | ||
34 | ]) | ||
35 | |||
36 | AC_DEFUN([FIND_ACODEC_SONAME], | ||
37 | [ | ||
38 | AC_MSG_CHECKING([for lib_$1_wrap_$2_elinux.so soname]) | ||
39 | - path=`$PKG_CONFIG --variable=libdir libfslaudiocodec | sed -e 's|.*/imx-mm/|/usr/lib/imx-mm/|'` | ||
40 | - SONAME=$( $CC -print-file-name=$path/wrap/lib_$1_wrap_$2_elinux.so | \ | ||
41 | + path=`$PKG_CONFIG --variable=libdir libfslaudiocodec` | ||
42 | + SONAME=$( $CC -print-file-name=$PKG_CONFIG_SYSROOT_DIR$path/wrap/lib_$1_wrap_$2_elinux.so | \ | ||
43 | while read output; do objdump -p $output | \ | ||
44 | grep "SONAME" | \ | ||
45 | sed -e 's/ \+SONAME \+//'; done 2> /dev/null ) | ||
46 | @@ -48,8 +47,7 @@ AC_DEFUN([FIND_ACODEC_SONAME], | ||
47 | AC_MSG_RESULT([$SONAME]) | ||
48 | fi | ||
49 | |||
50 | - apath=`echo $path | sed -e 's|.*/imx-mm/|/usr/lib/imx-mm/|'` | ||
51 | - $1_$2_SONAME=$apath/wrap/$SONAME | ||
52 | + $1_$2_SONAME=$path/wrap/$SONAME | ||
53 | AC_SUBST($1_$2_SONAME) | ||
54 | ]) | ||
55 | |||
56 | -- | ||
57 | 1.8.1 | ||
58 | |||
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch b/recipes-multimedia/gst-plugins/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch new file mode 100644 index 0000000..e06a250 --- /dev/null +++ b/recipes-multimedia/gst-plugins/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From 28ad25933dc51d8af13927a9943a353677c31a3a Mon Sep 17 00:00:00 2001 | ||
2 | From: Lyon Wang <lyon.wang@freescale.com> | ||
3 | Date: Tue, 22 Oct 2013 16:15:43 +0800 | ||
4 | Subject: [PATCH] remove GST_INFO in mfw_gst_utils.h | ||
5 | |||
6 | GST_INFO() should not be used in the global header | ||
7 | or it will cause some macro definiation error. | ||
8 | |||
9 | so comment the GST_INFO() in the mfw_gst_utils.h | ||
10 | |||
11 | Upstream-Status: Backport [GIT] | ||
12 | --- | ||
13 | inc/plugin/mfw_gst_utils.h | 4 ++-- | ||
14 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/inc/plugin/mfw_gst_utils.h b/inc/plugin/mfw_gst_utils.h | ||
17 | index 366d50e..c1b6f90 100755 | ||
18 | --- a/inc/plugin/mfw_gst_utils.h | ||
19 | +++ b/inc/plugin/mfw_gst_utils.h | ||
20 | @@ -876,7 +876,7 @@ getChipCodeFromSocid (void) | ||
21 | } | ||
22 | fclose(fp); | ||
23 | |||
24 | - GST_INFO("SOC is %s\n", soc_name); | ||
25 | + //GST_INFO("SOC is %s\n", soc_name); | ||
26 | |||
27 | int num = sizeof(soc_info) / sizeof(SOC_INFO); | ||
28 | int i; | ||
29 | @@ -913,7 +913,7 @@ getChipCode (void) | ||
30 | } | ||
31 | |||
32 | kv = ((kv_major << 16) + (kv_minor << 8) + kv_rel); | ||
33 | - GST_INFO("kernel:%s, %d.%d.%d\n", sys_name.release, kv_major, kv_minor, kv_rel); | ||
34 | + //GST_INFO("kernel:%s, %d.%d.%d\n", sys_name.release, kv_major, kv_minor, kv_rel); | ||
35 | |||
36 | if (kv < KERN_VER(3, 10, 0)) | ||
37 | return getChipCodeFromCpuinfo(); | ||
38 | -- | ||
39 | 1.7.9.5 | ||
40 | |||
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.8.bb b/recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.8.bb deleted file mode 100644 index ea0d26e..0000000 --- a/recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.8.bb +++ /dev/null | |||
@@ -1,15 +0,0 @@ | |||
1 | # Copyright (C) 2012-2013 Freescale Semiconductor | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | require gst-fsl-plugin.inc | ||
5 | |||
6 | SRC_URI[md5sum] = "fe298c831e107ae5b93df05c4c29bb65" | ||
7 | SRC_URI[sha256sum] = "6c3215f24dedabf97ad6a7bd5c8d088b01dc4cd4792c56e0df353ae03adb35ff" | ||
8 | |||
9 | # FIXME: Inspecting the source code the content is in fact 3.0.8 | ||
10 | SRC_URI = "${FSL_MIRROR}/gst-fsl-plugins-3.5.7-1.0.0.tar.gz" | ||
11 | S = "${WORKDIR}/gst-fsl-plugins-3.5.7-1.0.0" | ||
12 | |||
13 | SRC_URI_append += "file://configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch" | ||
14 | |||
15 | COMPATIBLE_MACHINE = "(mx28|mx5|mx6)" | ||
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.9.bb b/recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.9.bb new file mode 100644 index 0000000..52813a5 --- /dev/null +++ b/recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.9.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | # Copyright (C) 2013 Freescale Semiconductor | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | require gst-fsl-plugin.inc | ||
5 | |||
6 | # FIXME: Inspecting the source code the content is in fact 3.0.9 | ||
7 | SRC_URI = "${FSL_MIRROR}/gst-fsl-plugins-3.10.9-1.0.0.tar.gz \ | ||
8 | file://remove-GST_INFO-in-mfw_gst_utils.h.patch" | ||
9 | |||
10 | SRC_URI[md5sum] = "a338a5c25225c765ae5f44af82fe7413" | ||
11 | SRC_URI[sha256sum] = "e809daa0cd60381f05a79f34a53305a5ee53bfed22192a1cda6d998acc84a6fd" | ||
12 | |||
13 | S = "${WORKDIR}/gst-fsl-plugins-3.10.9-1.0.0" | ||
14 | |||
15 | COMPATIBLE_MACHINE = "(mx28|mx5|mx6)" | ||