diff options
Diffstat (limited to 'recipes-multimedia/libfslcodec/libfslcodec_3.0.5.bb')
-rw-r--r-- | recipes-multimedia/libfslcodec/libfslcodec_3.0.5.bb | 60 |
1 files changed, 60 insertions, 0 deletions
diff --git a/recipes-multimedia/libfslcodec/libfslcodec_3.0.5.bb b/recipes-multimedia/libfslcodec/libfslcodec_3.0.5.bb new file mode 100644 index 0000000..183bf26 --- /dev/null +++ b/recipes-multimedia/libfslcodec/libfslcodec_3.0.5.bb | |||
@@ -0,0 +1,60 @@ | |||
1 | # Copyright (C) 2012 Freescale Semicondutors | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | DESCRIPTION = "Freescale Multimedia codec libs" | ||
4 | LICENSE = "Proprietary" | ||
5 | SECTION = "multimedia" | ||
6 | LIC_FILES_CHKSUM = "file://EULA.txt;md5=ea4d5c069d7aef0838a110409ea78a01" | ||
7 | |||
8 | PR = "r1" | ||
9 | |||
10 | inherit fsl-eula-unpack autotools pkgconfig | ||
11 | |||
12 | SRC_URI[md5sum] = "dc08b569175981fc0bd5f97986cfd543" | ||
13 | SRC_URI[sha256sum] = "2a4a7248246ff37f30486f34918151f09493ecfcaeca0cd8155d5b5c93245138" | ||
14 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true" | ||
15 | |||
16 | PACKAGES_DYNAMIC = "${PN}-*" | ||
17 | |||
18 | do_install_append() { | ||
19 | # FIXME: This link points to nowhere | ||
20 | rm ${D}${libdir}/imx-mm/audio-codec/lib_src_ppp_arm11_elinux.so | ||
21 | |||
22 | # LTIB move the files around or gst-fsl-plugin won't find them | ||
23 | for p in $(find ${D}${libdir}/imx-mm -mindepth 1 -maxdepth 1 -type d); do | ||
24 | mv $p/* ${D}${libdir} | ||
25 | rmdir $p | ||
26 | done | ||
27 | rmdir ${D}${libdir}/imx-mm | ||
28 | |||
29 | # FIXME: Drop examples | ||
30 | rm -r ${D}${datadir}/imx-mm | ||
31 | } | ||
32 | |||
33 | python populate_packages_prepend() { | ||
34 | do_split_packages(d, d.getVar('libdir', True), '^lib_(.*)_elinux\.so\..*', | ||
35 | aux_files_pattern_verbatim='${libdir}/lib_%s_elinux.so.*', | ||
36 | output_pattern='libfslcodec-audio-%s', | ||
37 | description='Freescale IMX Codec (%s)', | ||
38 | extra_depends='', prepend=True) | ||
39 | |||
40 | wrapdir = bb.data.expand('${libdir}/wrap', d) | ||
41 | do_split_packages(d, wrapdir, '^lib_(.*)_elinux\.so\..*', | ||
42 | aux_files_pattern_verbatim='${libdir}/wrap/lib_%s_elinux.so.*', | ||
43 | output_pattern='libfslcodec-audio-wrap-%s', | ||
44 | description='Freescale IMX Codec Wrap (%s)', | ||
45 | extra_depends='', prepend=True) | ||
46 | |||
47 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | ||
48 | # the source we cannot fix it. Disable the insane check for now. | ||
49 | for p in d.getVar('PACKAGES', True).split(): | ||
50 | d.setVar("INSANE_SKIP_%s" % p, "ldflags") | ||
51 | } | ||
52 | |||
53 | # Ensure we get warnings if we miss something | ||
54 | FILES_${PN} = "" | ||
55 | |||
56 | FILES_${PN}-dev += "${libdir}/*/*${SOLIBSDEV} \ | ||
57 | ${libdir}/*/*/*${SOLIBSDEV}" | ||
58 | |||
59 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
60 | COMPATIBLE_MACHINE = "(mx6)" | ||