diff options
Diffstat (limited to 'recipes-multimedia/gstreamer')
-rw-r--r-- | recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.1.bb (renamed from recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.0.bb) | 37 |
1 files changed, 29 insertions, 8 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.0.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.1.bb index eaccb29..f968dbc 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.0.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.1.bb | |||
@@ -2,11 +2,9 @@ DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms" | |||
2 | LICENSE = "LGPLv2+" | 2 | LICENSE = "LGPLv2+" |
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605" | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605" |
4 | SECTION = "multimedia" | 4 | SECTION = "multimedia" |
5 | # gstreamer1.0-plugins-bad is in DEPENDS because imxv4l2videosrc requires | 5 | # gstreamer1.0-plugins-bad is in DEPENDS because the build script scans for the |
6 | # the GstPhotography headers and libraries | 6 | # GstPhotography headers and libraries |
7 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad imx-gpu-viv \ | 7 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad virtual/kernel" |
8 | libfslcodec libimxvpuapi virtual/kernel virtual/egl virtual/libgles2 \ | ||
9 | ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}" | ||
10 | # add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers | 8 | # add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers |
11 | # for the uniaudio decoder, videoparsersbad for the VPU video decoder | 9 | # for the uniaudio decoder, videoparsersbad for the VPU video decoder |
12 | # the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is | 10 | # the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good recipe is |
@@ -16,7 +14,7 @@ RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audiopar | |||
16 | RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad" | 14 | RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad" |
17 | 15 | ||
18 | SRCBRANCH ?= "master" | 16 | SRCBRANCH ?= "master" |
19 | SRCREV = "f8ad953c458be6a89f474a948b6401664a6a1745" | 17 | SRCREV = "11a7b366f211e54e0ec67c692287603a02640ff6" |
20 | SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}" | 18 | SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}" |
21 | 19 | ||
22 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
@@ -33,7 +31,30 @@ EGLVIVSINK_PLATFORM = "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', \ | |||
33 | base_contains('DISTRO_FEATURES', 'wayland', 'wayland', \ | 31 | base_contains('DISTRO_FEATURES', 'wayland', 'wayland', \ |
34 | 'fb', d),d)}" | 32 | 'fb', d),d)}" |
35 | 33 | ||
36 | EXTRA_OECONF = "--egl-platform=${EGLVIVSINK_PLATFORM} --kernel-headers=${STAGING_KERNEL_DIR}/include" | 34 | EGL_PLATFORM_CONF = "--egl-platform=${EGLVIVSINK_PLATFORM}" |
35 | EXTRA_OECONF = "--kernel-headers=${STAGING_KERNEL_DIR}/include" | ||
36 | |||
37 | EGLVIVSINK_DEPENDS = " \ | ||
38 | virtual/egl virtual/libgles2 \ | ||
39 | ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', \ | ||
40 | base_contains('DISTRO_FEATURES', 'wayland', 'wayland', \ | ||
41 | '', d),d)}" | ||
42 | |||
43 | PACKAGECONFIG ?= "" | ||
44 | PACKAGECONFIG_mx6q = "uniaudiodec mp3encoder v4l2src g2d eglvivsink ipu vpu" | ||
45 | PACKAGECONFIG_mx6dl = "uniaudiodec mp3encoder v4l2src pxp g2d eglvivsink ipu vpu" | ||
46 | PACKAGECONFIG_mx6sx = "uniaudiodec mp3encoder v4l2src pxp g2d eglvivsink" | ||
47 | PACKAGECONFIG_mx6sl = "uniaudiodec mp3encoder v4l2src pxp g2d" | ||
48 | PACKAGECONFIG_mx7 = "uniaudiodec mp3encoder v4l2src pxp" | ||
49 | |||
50 | PACKAGECONFIG[g2d] = ",--disable-g2d,imx-gpu-viv" | ||
51 | PACKAGECONFIG[pxp] = ",--disable-pxp," | ||
52 | PACKAGECONFIG[ipu] = ",--disable-ipu," | ||
53 | PACKAGECONFIG[vpu] = ",--disable-vpu,libimxvpuapi" | ||
54 | PACKAGECONFIG[eglvivsink] = "${EGL_PLATFORM_CONF},--disable-eglvivsink,${EGLVIVSINK_DEPENDS}" | ||
55 | PACKAGECONFIG[v4l2src] = ",--disable-v4l2src," | ||
56 | PACKAGECONFIG[uniaudiodec] = ",--disable-uniaudiodec,libfslcodec" | ||
57 | PACKAGECONFIG[mp3encoder] = ",--disable-mp3encoder,libfslcodec" | ||
37 | 58 | ||
38 | # LIBV is used by gst-plugins-package.inc to specify the GStreamer version (0.10 vs 1.0) | 59 | # LIBV is used by gst-plugins-package.inc to specify the GStreamer version (0.10 vs 1.0) |
39 | LIBV = "1.0" | 60 | LIBV = "1.0" |
@@ -42,7 +63,7 @@ require recipes-multimedia/gstreamer/gst-plugins-package.inc | |||
42 | # the following line is required to produce one package for each plugin | 63 | # the following line is required to produce one package for each plugin |
43 | PACKAGES_DYNAMIC = "^${PN}-.*" | 64 | PACKAGES_DYNAMIC = "^${PN}-.*" |
44 | 65 | ||
45 | COMPATIBLE_MACHINE = "(mx6)" | 66 | COMPATIBLE_MACHINE = "(mx6|mx7)" |
46 | 67 | ||
47 | # disable the false alarm (the "it isn't a build dependency" QA warning) | 68 | # disable the false alarm (the "it isn't a build dependency" QA warning) |
48 | INSANE_SKIP_gstreamer1.0-plugins-imx-imxaudio = "build-deps" | 69 | INSANE_SKIP_gstreamer1.0-plugins-imx-imxaudio = "build-deps" |