summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb
new file mode 100644
index 0000000..b168ef7
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.11.1.bb
@@ -0,0 +1,45 @@
1DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms"
2LICENSE = "LGPLv2+"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
4SECTION = "multimedia"
5DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base imx-gpu-viv libfslcodec libfslvpuwrap virtual/kernel virtual/egl \
6 virtual/libgles2 ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}"
7# add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers
8# for the uniaudio decoder, videoparsersbad for the VPU video decoder
9# the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good and -bad recipes are built
10RDEPENDS_gstreamer1.0-plugins-imx = "gstreamer1.0-plugins-good gstreamer1.0-plugins-bad"
11RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers"
12RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad"
13
14SRCBRANCH ?= "master"
15SRCREV = "6cbb90f51b12588bb4cb146cb229bf3bad39afc4"
16SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}"
17
18S = "${WORKDIR}/git"
19
20inherit waf
21
22do_compile[depends] += "virtual/kernel:do_shared_workdir"
23
24# configure the eglvivsink element to use the appropriate EGL platform code
25# X11 if x11 is present in DISTRO_FEATURES
26# Wayland if x11 is not present in DISTRO_FEATURES, but wayland is
27# Framebuffer otherwise
28EGLVIVSINK_PLATFORM = "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', \
29 base_contains('DISTRO_FEATURES', 'wayland', 'wayland', \
30 'fb', d),d)}"
31
32EXTRA_OECONF = "--egl-platform=${EGLVIVSINK_PLATFORM} --kernel-headers=${STAGING_KERNEL_DIR}/include"
33
34# LIBV is used by gst-plugins-package.inc to specify the GStreamer version (0.10 vs 1.0)
35LIBV = "1.0"
36require recipes-multimedia/gstreamer/gst-plugins-package.inc
37
38# the following line is required to produce one package for each plugin
39PACKAGES_DYNAMIC = "^${PN}-.*"
40
41COMPATIBLE_MACHINE = "(mx6)"
42
43# disable the false alarm (the "it isn't a build dependency" QA warning)
44INSANE_SKIP_gstreamer1.0-plugins-imx-imxaudio = "build-deps"
45INSANE_SKIP_gstreamer1.0-plugins-imx-imxvpu = "build-deps"