summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb
new file mode 100644
index 0000000..b7ba3c9
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.10.1.bb
@@ -0,0 +1,43 @@
1DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms"
2LICENSE = "LGPLv2+"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
4SECTION = "multimedia"
5DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base imx-gpu-viv libfslcodec libfslvpuwrap virtual/kernel virtual/egl \
6 virtual/libgles2 ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}"
7# add the audioparsers and the videoparsersbad plugins as RDEPENDS ; audioparsers
8# for the uniaudio decoder, videoparsersbad for the VPU video decoder
9# the gstreamer1.0-plugins-imx RDEPENDS is necessary to ensure the -good and -bad recipes are built
10RDEPENDS_gstreamer1.0-plugins-imx = "gstreamer1.0-plugins-good gstreamer1.0-plugins-bad"
11RDEPENDS_gstreamer1.0-plugins-imx-imxaudio = "gstreamer1.0-plugins-good-audioparsers"
12RDEPENDS_gstreamer1.0-plugins-imx-imxvpu = "gstreamer1.0-plugins-bad-videoparsersbad"
13
14SRCBRANCH ?= "master"
15SRCREV = "898e51dbdb01926d6423d0d31a9530ec6deb5192"
16SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}"
17
18S = "${WORKDIR}/git"
19
20inherit waf
21
22# configure the eglvivsink element to use the appropriate EGL platform code
23# X11 if x11 is present in DISTRO_FEATURES
24# Wayland if x11 is not present in DISTRO_FEATURES, but wayland is
25# Framebuffer otherwise
26EGLVIVSINK_PLATFORM = "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', \
27 base_contains('DISTRO_FEATURES', 'wayland', 'wayland', \
28 'fb', d),d)}"
29
30EXTRA_OECONF = "--egl-platform=${EGLVIVSINK_PLATFORM} --kernel-headers=${STAGING_KERNEL_DIR}/include"
31
32# LIBV is used by gst-plugins-package.inc to specify the GStreamer version (0.10 vs 1.0)
33LIBV = "1.0"
34require recipes-multimedia/gstreamer/gst-plugins-package.inc
35
36# the following line is required to produce one package for each plugin
37PACKAGES_DYNAMIC = "^${PN}-.*"
38
39COMPATIBLE_MACHINE = "(mx6)"
40
41# disable the false alarm (the "it isn't a build dependency" QA warning)
42INSANE_SKIP_gstreamer1.0-plugins-imx-imxaudio = "build-deps"
43INSANE_SKIP_gstreamer1.0-plugins-imx-imxvpu = "build-deps"