summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.8.bb')
-rw-r--r--recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.8.bb81
1 files changed, 81 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.8.bb b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.8.bb
new file mode 100644
index 0000000..51ea92a
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.8.bb
@@ -0,0 +1,81 @@
1# Copyright (C) 2014,2015 Freescale Semiconductor
2# Copyright (C) 2012-2015 O.S. Systems Software LTDA.
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "Gstreamer freescale plugins"
6LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1"
7SECTION = "multimedia"
8
9DEPENDS = "libfslcodec libfslparser virtual/kernel gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
10DEPENDS_append_mx6q = " imx-lib imx-vpu libfslvpuwrap"
11DEPENDS_append_mx6dl = " imx-lib imx-vpu libfslvpuwrap"
12DEPENDS_append_mx6sl = " imx-lib"
13DEPENDS_append_mx6sx = " imx-lib"
14DEPENDS_append_mx6ul = " imx-lib"
15DEPENDS_append_mx7 = " imx-lib"
16
17LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
18 file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
19 file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
20
21SRC_URI = " \
22 ${FSL_MIRROR}/gst1.0-fsl-plugins-${PV}.tar.gz \
23 file://0001-gst1.0-fsl-plugins-fix-appending-data-to-variable.patch \
24"
25
26SRC_URI[md5sum] = "0669eeea4e37203e2e654a00ded35ba2"
27SRC_URI[sha256sum] = "43c86f88d3c7b1da8d38815eaec297a9b8652e1fb770ff89c26d617f63ea068b"
28
29S = "${WORKDIR}/gst1.0-fsl-plugins-${PV}"
30
31inherit autotools pkgconfig
32
33# Make sure kernel sources are available
34do_configure[depends] += "virtual/kernel:do_shared_workdir"
35
36PLATFORM_mx6 = "MX6"
37PLATFORM_mx6sl = "MX6SL"
38PLATFORM_mx6sx = "MX6SX"
39PLATFORM_mx6ul = "MX6UL"
40PLATFORM_mx7= "MX7D"
41
42# Todo add a mechanism to map possible build targets
43EXTRA_OECONF = "PLATFORM=${PLATFORM} \
44 CPPFLAGS="-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include" \
45 CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR} \
46 ${@base_contains('DISTRO_FEATURES', 'wayland', base_contains('DISTRO_FEATURES', 'x11', '--disable-x11', '', d), '', d)}"
47
48PACKAGES =+ "${PN}-gplay ${PN}-libgplaycore ${PN}-libgstfsl ${PN}-grecorder ${PN}-librecorder-engine ${PN}-libplayengine"
49
50# Add codec list that the beep plugin run-time depended
51BEEP_RDEPENDS = "libfslcodec-aac libfslcodec-mp3 libfslcodec-oggvorbis"
52RDEPENDS_${PN} += "libfslparser ${BEEP_RDEPENDS} gstreamer1.0-plugins-good-id3demux "
53
54PACKAGECONFIG ?= ""
55PACKAGECONFIG_mx6 = "overlaysink"
56
57
58# FIXME: Add all features
59# feature from excluded mm packages
60PACKAGECONFIG[ac3] += ",,libfslac3codec,libfslac3codec"
61# feature from special mm packages
62PACKAGECONFIG[aacp] += ",,libfslaacpcodec,libfslaacpcodec"
63MSDEPENDS = "libfslmsparser libfslmscodec"
64PACKAGECONFIG[wma10dec] += ",,${MSDEPENDS},${MSDEPENDS}"
65PACKAGECONFIG[wma8enc] += "--enable-wma8enc,--disable-wma8enc,${MSDEPENDS},${MSDEPENDS}"
66OVDEPENDS = "virtual/libg2d"
67PACKAGECONFIG[overlaysink] += "--enable-overlaysink,--disable-overlaysink, ${OVDEPENDS}"
68
69FILES_${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}"
70
71FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
72FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc"
73FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
74FILES_${PN}-gplay = "${bindir}/gplay-1.0"
75FILES_${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}"
76FILES_${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}"
77FILES_${PN}-grecorder = "${bindir}/grecorder-1.0"
78FILES_${PN}-librecorder-engine = "${libdir}/librecorder_engine-1.0${SOLIBS}"
79FILES_${PN}-libplayengine = "${libdir}/libplayengine-1.0${SOLIBS}"
80
81COMPATIBLE_MACHINE = "(mx6|mx6ul|mx7)"