summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.3.bb')
-rw-r--r--recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.3.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.3.bb b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.3.bb
new file mode 100644
index 0000000..dd761b6
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.3.bb
@@ -0,0 +1,39 @@
1# Copyright (C) 2014,2015 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require gst-fsl-plugin.inc
5
6SRC_URI = "${FSL_MIRROR}/gst1.0-fsl-plugins-${PV}.tar.gz"
7S = "${WORKDIR}/gst1.0-fsl-plugins-${PV}"
8
9EXTRA_OECONF += " CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR}"
10
11SRC_URI[md5sum] = "b5c1072536479c174bda1349ade5d10c"
12SRC_URI[sha256sum] = "9d5c051cbde023014e67fde07bc314b6b9a5e7030e24eb0d8afdf33e7e458125"
13
14DEPENDS_append = " gstreamer1.0 gstreamer1.0-plugins-base"
15RDEPENDS_${PN} += "gstreamer1.0-plugins-good-id3demux"
16
17PACKAGECONFIG ?= ""
18PACKAGECONFIG_mx6 = "overlaysink"
19
20# FIXME: Add all features
21# feature from excluded mm packages
22PACKAGECONFIG[ac3] += ",,libfslac3codec,libfslac3codec"
23# feature from special mm packages
24PACKAGECONFIG[aacp] += ",,libfslaacpcodec,libfslaacpcodec"
25MSDEPENDS = "libfslmsparser libfslmscodec"
26PACKAGECONFIG[wma10dec] += ",,${MSDEPENDS},${MSDEPENDS}"
27PACKAGECONFIG[wma8enc] += "--enable-wma8enc,--disable-wma8enc,${MSDEPENDS},${MSDEPENDS}"
28OVDEPENDS = "virtual/libg2d"
29PACKAGECONFIG[overlaysink] += "--enable-overlaysink,--disable-overlaysink, ${OVDEPENDS}"
30
31FILES_${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}"
32FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
33FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc"
34FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
35FILES_${PN}-gplay = "${bindir}/gplay-1.0"
36FILES_${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}"
37FILES_${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}"
38
39COMPATIBLE_MACHINE = "(mx6)"