summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch')
-rw-r--r--recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch63
1 files changed, 0 insertions, 63 deletions
diff --git a/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch b/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch
deleted file mode 100644
index 02b5208..0000000
--- a/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch
+++ /dev/null
@@ -1,63 +0,0 @@
1From be38dc1816d4de1a1b463988763f50226eb8417f Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Thu, 7 Nov 2013 10:50:51 -0200
4Subject: [PATCH] configure.ac: Fix checking for include headers in multiple
5 paths
6Organization: O.S. Systems Software LTDA.
7
8This fixes the support for proper detecting Freescale specific headers
9in include/linux and include/uapi.
10
11Without this patch we have the configure log with the same feature in
12'enabled' and 'disabled' state and it was impossible to override the
13CPPFLAGS.
14
15Upstream-Status: Pending
16
17Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
18---
19 configure.ac | 19 ++++++++-----------
20 1 file changed, 8 insertions(+), 11 deletions(-)
21
22diff --git a/configure.ac b/configure.ac
23index d74ee0e..f11c76c 100755
24--- a/configure.ac
25+++ b/configure.ac
26@@ -58,13 +58,9 @@ AC_DEFUN([CHECK_DISABLE_FEATURE],
27 [use_[$1]=$enableval],
28 [use_[$1]=yes])
29 if test "$use_[$1]" = "yes"; then
30- SAVE_CPPFLAGS="$CPPFLAGS"
31- CPPFLAGS=`$PKG_CONFIG --cflags libfslaudiocodec`
32- CPPFLAGS+=`$PKG_CONFIG --cflags libfslvideocodec`
33- CPPFLAGS+=`$PKG_CONFIG --cflags libfslparser`
34- CPPFLAGS+=`$PKG_CONFIG --cflags libfslvpuwrap`
35- AC_CHECK_HEADERS([$4], HAVE_[$3]=yes, HAVE_[$3]=no && break)
36- CPPFLAGS="$SAVE_CPPFLAGS"
37+ for h in "$4"; do
38+ AC_CHECK_HEADERS([$h], HAVE_[$3]=yes && break, HAVE_[$3]=no)
39+ done
40 if test "x$HAVE_[$3]" = "xyes"; then
41 enabled_feature="$enabled_feature\n\t\t[$5]"
42 else
43@@ -283,12 +279,13 @@ CHECK_DISABLE_FEATURE(beep, [Disable beep audio decoder], [BEEP], [fsl_unia.h],
44
45 CHECK_DISABLE_FEATURE(v4lsink, [Disable fsl v4l sink], [V4L_SINK], [linux/videodev2.h], [plugin: v4lsink])
46
47+# Allow headers to be inside include/uapi and include/linux
48 saved_CFLAGS="$CFLAGS"
49 CFLAGS="$CFLAGS $IPU_CFLAGS"
50-CHECK_DISABLE_FEATURE(isink, [Disable fsl ipu sink], [I_SINK], [linux/mxcfb.h], [plugin: isink])
51-CHECK_DISABLE_FEATURE(isink, [Disable fsl ipu sink], [I_SINK], [uapi/mxcfb.h], [plugin: isink])
52-CHECK_DISABLE_FEATURE(ipucsc, [Disable fsl ipu csc], [I_CSC], [linux/mxcfb.h], [plugin: ipucsc])
53-CHECK_DISABLE_FEATURE(ipucsc, [Disable fsl ipu csc], [I_CSC], [uapi/mxcfb.h], [plugin: ipucsc])
54+
55+CHECK_DISABLE_FEATURE(isink, [Disable fsl ipu sink], [I_SINK], [linux/mxcfb.h uapi/mxcfb.h], [plugin: isink])
56+CHECK_DISABLE_FEATURE(ipucsc, [Disable fsl ipu csc], [I_CSC], [linux/mxcfb.h uapi/mxcfb.h], [plugin: ipucsc])
57+
58 CFLAGS=$saved_CFLAGS
59
60 CHECK_DISABLE_FEATURE(ipulib, [Disable ipu lib], [IPU_LIB], [mxc_ipu_hl_lib.h], [library: libipu])
61--
621.8.4.rc3
63