summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gst-plugins/gst-fsl-plugin/configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/gst-plugins/gst-fsl-plugin/configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch')
-rw-r--r--recipes-multimedia/gst-plugins/gst-fsl-plugin/configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch58
1 files changed, 0 insertions, 58 deletions
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin/configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch b/recipes-multimedia/gst-plugins/gst-fsl-plugin/configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch
deleted file mode 100644
index cab9ff4..0000000
--- a/recipes-multimedia/gst-plugins/gst-fsl-plugin/configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch
+++ /dev/null
@@ -1,58 +0,0 @@
1From 6f75a9f4ad108c1f4a3dff4dd08def174ab83a69 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Tue, 21 May 2013 16:43:31 -0300
4Subject: [PATCH] configure.ac: Use pkg-config sysroot when checking for soname
5
6Upstream-Status: Pending
7
8Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
9---
10 configure.ac | 12 +++++-------
11 1 file changed, 5 insertions(+), 7 deletions(-)
12
13diff --git a/configure.ac b/configure.ac
14index e4cdb86..c12ceb4 100755
15--- a/configure.ac
16+++ b/configure.ac
17@@ -16,7 +16,7 @@ AC_DEFUN([FIND_PARSER_SONAME],
18 [
19 AC_MSG_CHECKING([for lib_$1_parser_$2_elinux.3.0.so soname])
20 path=`$PKG_CONFIG --variable=libdir libfslparser`
21- SONAME=$( $CC -print-file-name=$path/lib_$1_parser_$2_elinux.so | \
22+ SONAME=$( $CC -print-file-name=$PKG_CONFIG_SYSROOT_DIR$path/lib_$1_parser_$2_elinux.so | \
23 while read output; do objdump -p $output | \
24 grep "SONAME" | \
25 sed -e 's/ \+SONAME \+//'; done 2> /dev/null )
26@@ -27,16 +27,15 @@ AC_DEFUN([FIND_PARSER_SONAME],
27 else
28 AC_MSG_RESULT([$SONAME])
29 fi
30- apath=`echo $path | sed -e 's|.*/imx-mm/|/usr/lib/imx-mm/|'`
31- $1_$2_SONAME=$apath/$SONAME
32+ $1_$2_SONAME=$path/$SONAME
33 AC_SUBST($1_$2_SONAME)
34 ])
35
36 AC_DEFUN([FIND_ACODEC_SONAME],
37 [
38 AC_MSG_CHECKING([for lib_$1_wrap_$2_elinux.so soname])
39- path=`$PKG_CONFIG --variable=libdir libfslaudiocodec | sed -e 's|.*/imx-mm/|/usr/lib/imx-mm/|'`
40- SONAME=$( $CC -print-file-name=$path/wrap/lib_$1_wrap_$2_elinux.so | \
41+ path=`$PKG_CONFIG --variable=libdir libfslaudiocodec`
42+ SONAME=$( $CC -print-file-name=$PKG_CONFIG_SYSROOT_DIR$path/wrap/lib_$1_wrap_$2_elinux.so | \
43 while read output; do objdump -p $output | \
44 grep "SONAME" | \
45 sed -e 's/ \+SONAME \+//'; done 2> /dev/null )
46@@ -48,8 +47,7 @@ AC_DEFUN([FIND_ACODEC_SONAME],
47 AC_MSG_RESULT([$SONAME])
48 fi
49
50- apath=`echo $path | sed -e 's|.*/imx-mm/|/usr/lib/imx-mm/|'`
51- $1_$2_SONAME=$apath/wrap/$SONAME
52+ $1_$2_SONAME=$path/wrap/$SONAME
53 AC_SUBST($1_$2_SONAME)
54 ])
55
56--
571.8.1
58