summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx-2.6.35.3/perf-avoid-use-sysroot-headers.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-imx-2.6.35.3/perf-avoid-use-sysroot-headers.patch')
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/perf-avoid-use-sysroot-headers.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/perf-avoid-use-sysroot-headers.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/perf-avoid-use-sysroot-headers.patch
new file mode 100644
index 0000000..7d12941
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-2.6.35.3/perf-avoid-use-sysroot-headers.patch
@@ -0,0 +1,33 @@
1From 9a06d08e43923f8ce35f1c649334f14d2e81941b Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Tue, 19 Mar 2013 14:04:08 -0300
4Subject: [PATCH] perf: Avoid use of sysroot's Linux headers
5
6As Yocto now use a newer Linux headers package we end having a build
7failure in perf as 'stddef.h' has changed and does not provide NULL
8definiton anymore. To workaround it we add the srcdir onto search path
9for include files, before sysroot one.
10
11Upstream-Status: Inappropriate [build system specific change]
12
13Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
14---
15 tools/perf/Makefile | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/tools/perf/Makefile b/tools/perf/Makefile
19index 854652a..9605d46 100644
20--- a/tools/perf/Makefile
21+++ b/tools/perf/Makefile
22@@ -301,7 +301,7 @@ endif
23 # Those must not be GNU-specific; they are shared with perl/ which may
24 # be built by a different compiler. (Note that this is an artifact now
25 # but it still might be nice to keep that distinction.)
26-BASIC_CFLAGS = -Iutil/include -Iarch/$(ARCH)/include
27+BASIC_CFLAGS = -Iutil/include -Iarch/$(ARCH)/include -I../../include
28 BASIC_LDFLAGS =
29
30 # Guard against environment variables
31--
321.8.1
33