summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-fslc-imx-rt_4.1-1.0.x.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-fslc-imx-rt_4.1-1.0.x.bb')
-rw-r--r--recipes-kernel/linux/linux-fslc-imx-rt_4.1-1.0.x.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx-rt_4.1-1.0.x.bb b/recipes-kernel/linux/linux-fslc-imx-rt_4.1-1.0.x.bb
new file mode 100644
index 0000000..d40c4cf
--- /dev/null
+++ b/recipes-kernel/linux/linux-fslc-imx-rt_4.1-1.0.x.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Realtime version of the FSL Community BSP i.MX6 Linux kernel with backported features and fixes"
2DESCRIPTION = "Linux kernel based on Freescale 3.14.52-1.1.0 GA release, used by FSL Community BSP in order to \
3provide support for i.MX6 based platforms and include official Linux kernel stable updates, backported \
4features and fixes coming from the vendors, kernel community or FSL Community itself. \
5In addition, this kernel has the realtime patch (PREEMPT_RT) applied."
6
7include linux-fslc.inc
8
9PV .= "+git${SRCPV}"
10
11SRCBRANCH = "4.1-1.0.x-imx"
12SRCREV = "445b81a703861b3c146ccd074cb5c14a5363c6d3"
13
14SRC_URI += " \
15 https://www.kernel.org/pub/linux/kernel/projects/rt/4.1/older/patch-4.1.19-rt22.patch.gz;name=patch-4.1.19-rt22.patch \
16 file://0001-fix-build.patch \
17 file://0002-no-split-ptlocks.patch \
18 file://0003-Work-around-CPU-stalls-in-the-imx-sdma-driver.patch \
19"
20
21SRC_URI[patch-4.1.19-rt22.patch.md5sum] = "20a893d189c619ea3e7489f870478e7a"
22SRC_URI[patch-4.1.19-rt22.patch.sha256sum] = "81a6429eb03f085e7f58a669eb23719ae14876c14fe244f5aac909c28ee4104e"
23
24python () {
25 using_builtin_driver = (d.getVar("MACHINE_USES_VIVANTE_KERNEL_DRIVER_MODULE", True) or "") != "1"
26 if not using_builtin_driver:
27 raise bb.parse.SkipPackage('You must use the builtin driver with the Linux RT patch as the external module does not yet include support for it. Set "MACHINE_USES_VIVANTE_KERNEL_DRIVER_MODULE" accordingly.')
28}
29
30
31COMPATIBLE_MACHINE = "(mx6|mx7)"