summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb')
-rw-r--r--recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb b/recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb
new file mode 100644
index 0000000..a77e4ab
--- /dev/null
+++ b/recipes-graphics/xorg-driver/xf86-video-imxfb_11.05.01.bb
@@ -0,0 +1,26 @@
1# Copyright (C) 2011 Freescale
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "X.Org X server -- Freescale iMx framebuffer driver"
5LICENSE = "MIT-X"
6RDEPENDS = "amd-gpu-x11-bin-mx51"
7DEPENDS = "virtual/xserver-xf86 virtual/libx11 xproto randrproto util-macros amd-gpu-x11-bin-mx51"
8LIC_FILES_CHKSUM = "file://COPYING;md5=f7bdc0c63080175d1667091b864cb12c"
9
10inherit autotools pkgconfig
11
12PR = "r0"
13SRC_URI = "http://opensource.freescale.com/pub/scm/imx/xserver-xorg-video-imx-${PV}.tar.gz \
14 file://xf86-video-imxfb-fix-m4-hardcodded-paths.patch"
15
16FILES_${PN} += " ${libdir}/xorg/modules/drivers/*.so"
17FILES_${PN}-dbg += " ${libdir}/xorg/modules/drivers/.debug"
18EXTRA_OECONF_armv7a = " --enable-neon "
19CFLAGS += " -I${STAGING_INCDIR}/xorg "
20
21S = "${WORKDIR}/xserver-xorg-video-imx-${REL}"
22
23do_install_append () {
24 # driver's la files are not packaged
25 rm -f ${D}${libdir}/xorg/modules/drivers/*.la
26}