summaryrefslogtreecommitdiffstats
path: root/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb')
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
new file mode 100644
index 0000000..92f882d
--- /dev/null
+++ b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
@@ -0,0 +1,47 @@
1# Copyright (C) 2014 O.S. Systems Software LTDA.
2
3SUMMARY = "Freescale Manufacturing Tool requirements"
4LICENSE = "MIT"
5
6inherit packagegroup
7
8PACKAGES = " \
9 ${PN}-base \
10 ${PN}-mtd \
11 ${PN}-extfs \
12"
13
14# The essential packages for device bootup that may be set in the
15# machine configuration file.
16MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
17
18# Distro can override the following VIRTUAL-RUNTIME providers:
19VIRTUAL-RUNTIME_keymaps ?= "keymaps"
20
21RDEPENDS_${PN}-base = " \
22 bash \
23 imx-uuc \
24 util-linux \
25 coreutils \
26 dosfstools \
27 mmc-utils \
28 base-files \
29 base-passwd \
30 busybox \
31 ${@base_contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
32 ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
33"
34
35RDEPENDS_${PN}-mtd = " \
36 ${PN}-base \
37 imx-kobs \
38 mtd-utils \
39 mtd-utils-ubifs \
40"
41
42RDEPENDS_${PN}-extfs = " \
43 ${PN}-base \
44 e2fsprogs-mke2fs \
45"
46
47PACKAGE_ARCH = "${MACHINE_ARCH}"