summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot')
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2009.08.bb5
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2013.04.bb4
2 files changed, 8 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
index 393e7f3..7b31cc8 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
@@ -54,7 +54,9 @@ UBOOT_MAKE_TARGET = "u-boot.bin"
54S = "${WORKDIR}/git" 54S = "${WORKDIR}/git"
55EXTRA_OEMAKE += 'HOSTSTRIP=true' 55EXTRA_OEMAKE += 'HOSTSTRIP=true'
56 56
57PACKAGE_ARCH = "${MACHINE_ARCH}" 57inherit fsl-u-boot-localversion
58
59LOCALVERSION = "+imx"
58 60
59do_compile_prepend() { 61do_compile_prepend() {
60 if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then 62 if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
@@ -63,3 +65,4 @@ do_compile_prepend() {
63} 65}
64 66
65COMPATIBLE_MACHINE = "(imx28evk|mx5|mx6)" 67COMPATIBLE_MACHINE = "(imx28evk|mx5|mx6)"
68PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/u-boot/u-boot-imx_2013.04.bb b/recipes-bsp/u-boot/u-boot-imx_2013.04.bb
index 1c0f828..867f0ed 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2013.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2013.04.bb
@@ -14,5 +14,9 @@ SRCREV = "ce0ea2507c492d43bbf88f8609482a171b2d2003"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit fsl-u-boot-localversion
18
19LOCALVERSION = "+imx"
20
17PACKAGE_ARCH = "${MACHINE_ARCH}" 21PACKAGE_ARCH = "${MACHINE_ARCH}"
18COMPATIBLE_MACHINE = "(mx6)" 22COMPATIBLE_MACHINE = "(mx6)"