summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-mxsboot_2013.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-mxsboot_2013.01.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-mxsboot_2013.01.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-mxsboot_2013.01.bb b/recipes-bsp/u-boot/u-boot-mxsboot_2013.01.bb
new file mode 100644
index 0000000..4e541b1
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-mxsboot_2013.01.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "U-boot bootloader mxsboot tool"
2LICENSE = "GPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
4SECTION = "bootloader"
5
6PV = "v2013.01"
7
8SRCREV = "d55bd2b60645e3331f7b12f9251c1eeada44b505"
9SRC_URI = "git://github.com/Freescale/u-boot-imx.git"
10
11S = "${WORKDIR}/git"
12
13EXTRA_OEMAKE = 'HOSTCC="${CC}" HOSTLD="${LD}" HOSTSTRIP=true CONFIG_MX28=y'
14
15do_compile () {
16 oe_runmake tools
17}
18
19do_install () {
20 install -d ${D}${bindir}
21 install -m 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
22 ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
23}
24
25BBCLASSEXTEND = "native nativesdk"