summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-ls1_2015.01.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1_2015.01.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb b/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
new file mode 100644
index 0000000..716105f
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-ls1_2015.01.bb
@@ -0,0 +1,48 @@
1require recipes-bsp/u-boot/u-boot.inc
2
3DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ Layerscape1 boards"
4LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
8 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
9 file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
10 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
11"
12
13SRCBRANCH = "master"
14SRC_URI = "git://git.freescale.com/ppc/sdk/u-boot.git;branch=${SRCBRANCH}"
15SRCREV = "6ba8eedbcdc4b063f59a63e6288b938af739e8ad"
16
17LOCALVERSION ?= "+ls1"
18
19S = "${WORKDIR}/git"
20
21inherit fsl-u-boot-localversion
22
23DEPENDS += "change-file-endianess-native dtc-native"
24PROVIDES += "u-boot"
25
26do_compile_append () {
27 if [ "x${UBOOT_CONFIG}" != "x" ]
28 then
29 for config in ${UBOOT_MACHINE}; do
30 case "${config}" in
31 *spi*) tclsh ${STAGING_BINDIR_NATIVE}/byte_swap.tcl ${S}/${config}/u-boot-dtb.bin ${S}/${config}/u-boot.swap.bin 8
32 mv ${S}/${config}/u-boot.swap.bin ${S}/u-boot-${type}.${UBOOT_SUFFIX};;
33 *sdcard*) mv ${S}/${config}/u-boot-with-spl-pbl.bin ${S}/${config}/u-boot.bin;;
34 *nand*) mv ${S}/u-boot-with-spl-pbl.bin ${S}/u-boot.bin;;
35 esac
36 done
37 fi
38
39}
40
41PACKAGES += "${PN}-images"
42FILES_${PN}-images += "/boot"
43
44ALLOW_EMPTY_${PN} = "1"
45
46PACKAGE_ARCH = "${MACHINE_ARCH}"
47COMPATIBLE_MACHINE = "(ls102xa)"
48