summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-2012.04.01/0034-imx-Add-u-boot.imx-as-target-for-ARM9-i.MX-SOCs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-2012.04.01/0034-imx-Add-u-boot.imx-as-target-for-ARM9-i.MX-SOCs.patch')
-rw-r--r--recipes-bsp/u-boot/u-boot-2012.04.01/0034-imx-Add-u-boot.imx-as-target-for-ARM9-i.MX-SOCs.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-2012.04.01/0034-imx-Add-u-boot.imx-as-target-for-ARM9-i.MX-SOCs.patch b/recipes-bsp/u-boot/u-boot-2012.04.01/0034-imx-Add-u-boot.imx-as-target-for-ARM9-i.MX-SOCs.patch
new file mode 100644
index 0000000..692d16a
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-2012.04.01/0034-imx-Add-u-boot.imx-as-target-for-ARM9-i.MX-SOCs.patch
@@ -0,0 +1,28 @@
1From b2f6a61134714190757c7aa81c3ed935cff106fa Mon Sep 17 00:00:00 2001
2From: Timo Ketola <timo@exertus.fi>
3Date: Wed, 18 Apr 2012 22:55:35 +0000
4Subject: [PATCH 34/56] imx: Add u-boot.imx as target for ARM9 i.MX SOCs
5
6Signed-off-by: Timo Ketola <timo@exertus.fi>
7Acked-by: Stefano Babic <sbabic@denx.de>
8---
9 arch/arm/cpu/arm926ejs/config.mk | 6 ++++++
10 1 file changed, 6 insertions(+)
11
12diff --git a/arch/arm/cpu/arm926ejs/config.mk b/arch/arm/cpu/arm926ejs/config.mk
13index ffb2e6c..6a3a1bb 100644
14--- a/arch/arm/cpu/arm926ejs/config.mk
15+++ b/arch/arm/cpu/arm926ejs/config.mk
16@@ -31,3 +31,9 @@ PLATFORM_CPPFLAGS += -march=armv5te
17 # =========================================================================
18 PF_RELFLAGS_SLB_AT := $(call cc-option,-mshort-load-bytes,$(call cc-option,-malignment-traps,))
19 PLATFORM_RELFLAGS += $(PF_RELFLAGS_SLB_AT)
20+
21+ifneq ($(CONFIG_IMX_CONFIG),)
22+
23+ALL-y += $(obj)u-boot.imx
24+
25+endif
26--
271.7.10
28