summaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb')
-rw-r--r--recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb22
1 files changed, 11 insertions, 11 deletions
diff --git a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
index 367e83b..6084f16 100644
--- a/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
+++ b/recipes-bsp/imx-bootlets/imx-bootlets_10.12.01.bb
@@ -23,12 +23,12 @@ EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
23 23
24# Ensure machine defines the IMXBOOTLETS_MACHINE 24# Ensure machine defines the IMXBOOTLETS_MACHINE
25python () { 25python () {
26 if not d.getVar("IMXBOOTLETS_MACHINE", True): 26 if not d.getVar("IMXBOOTLETS_MACHINE", True):
27 PN = d.getVar("PN", True) 27 PN = d.getVar("PN", True)
28 FILE = os.path.basename(d.getVar("FILE", True)) 28 FILE = os.path.basename(d.getVar("FILE", True))
29 bb.debug(1, "To build %s, see %s for instructions on \ 29 bb.debug(1, "To build %s, see %s for instructions on \
30 setting up your machine config" % (PN, FILE)) 30 setting up your machine config" % (PN, FILE))
31 raise bb.parse.SkipPackage("because IMXBOOTLETS_MACHINE is not set") 31 raise bb.parse.SkipPackage("because IMXBOOTLETS_MACHINE is not set")
32} 32}
33 33
34do_configure () { 34do_configure () {
@@ -60,11 +60,11 @@ FILES_${PN} = "/boot"
60do_deploy () { 60do_deploy () {
61 install -d ${DEPLOYDIR} 61 install -d ${DEPLOYDIR}
62 62
63 for f in boot_prep/boot_prep \ 63 for f in boot_prep/boot_prep \
64 power_prep/power_prep \ 64 power_prep/power_prep \
65 linux_prep/output-target/linux_prep \ 65 linux_prep/output-target/linux_prep \
66 barebox_ivt.bd \ 66 barebox_ivt.bd \
67 linux.bd linux.bd-dtb; do 67 linux.bd linux.bd-dtb; do
68 full_name="imx-bootlets-`basename $f`-${MACHINE}-${PV}-${PR}" 68 full_name="imx-bootlets-`basename $f`-${MACHINE}-${PV}-${PR}"
69 symlink_name="imx-bootlets-`basename $f`-${MACHINE}" 69 symlink_name="imx-bootlets-`basename $f`-${MACHINE}"
70 70