diff options
Diffstat (limited to 'qt5-layer/recipes-qt/qt5')
-rw-r--r-- | qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | 20 |
1 files changed, 18 insertions, 2 deletions
diff --git a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend index 20fc15f..64966c2 100644 --- a/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend +++ b/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend | |||
@@ -6,12 +6,21 @@ SRC_URI += "file://Force_egl_visual_ID_33.patch" | |||
6 | 6 | ||
7 | HAS_X11 = "${@base_contains('DISTRO_FEATURES', 'x11', 1, 0, d)}" | 7 | HAS_X11 = "${@base_contains('DISTRO_FEATURES', 'x11', 1, 0, d)}" |
8 | 8 | ||
9 | IS_MX6SL = "0" | ||
10 | IS_MX6SL_mx6sl = "1" | ||
11 | |||
9 | PACKAGECONFIG_GL_mx5 = "gles2" | 12 | PACKAGECONFIG_GL_mx5 = "gles2" |
10 | PACKAGECONFIG_append_mx5 = " tslib icu examples" | 13 | PACKAGECONFIG_append_mx5 = " tslib icu examples" |
11 | 14 | ||
12 | PACKAGECONFIG_GL_mx6 = "gles2" | 15 | PACKAGECONFIG_GL_mx6q = "gles2" |
16 | PACKAGECONFIG_GL_mx6dl = "gles2" | ||
17 | PACKAGECONFIG_GL_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
18 | ' gl', '', d)}" | ||
13 | PACKAGECONFIG_append_mx6 = " tslib icu examples" | 19 | PACKAGECONFIG_append_mx6 = " tslib icu examples" |
14 | QT_CONFIG_FLAGS_append_mx6 = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | 20 | QT_CONFIG_FLAGS_append_mx6q = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" |
21 | QT_CONFIG_FLAGS_append_mx6dl = "${@base_contains('DISTRO_FEATURES', 'x11', ' -no-eglfs', ' -eglfs', d)}" | ||
22 | QT_CONFIG_FLAGS_append_mx6sl = "${@base_contains('DISTRO_FEATURES', 'x11', \ | ||
23 | ' -no-eglfs', ' -no-opengl -linuxfb -no-icu -no-eglfs', d)}" | ||
15 | 24 | ||
16 | do_configure_prepend_mx5() { | 25 | do_configure_prepend_mx5() { |
17 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf | 26 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf |
@@ -36,10 +45,17 @@ do_configure_prepend_mx6() { | |||
36 | # adapt qmake.conf to our needs | 45 | # adapt qmake.conf to our needs |
37 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf | 46 | sed -i 's!load(qt_config)!!' ${S}/mkspecs/linux-oe-g++/qmake.conf |
38 | if test ${HAS_X11} -eq 0; then | 47 | if test ${HAS_X11} -eq 0; then |
48 | if test ${IS_MX6SL} -eq 0; then | ||
49 | |||
39 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | 50 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF |
40 | EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/qeglfshooks_imx6.cpp | 51 | EGLFS_PLATFORM_HOOKS_SOURCES = \$\$PWD/qeglfshooks_imx6.cpp |
41 | IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 | 52 | IMX6_CFLAGS = -DLINUX=1 -DEGL_API_FB=1 |
42 | EOF | 53 | EOF |
54 | else | ||
55 | cat >> ${S}/mkspecs/linux-oe-g++/qmake.conf <<EOF | ||
56 | IMX6_CFLAGS = -DLINUX=1 | ||
57 | EOF | ||
58 | fi | ||
43 | # copy the hook in the mkspecs directory OE is using | 59 | # copy the hook in the mkspecs directory OE is using |
44 | cp ${S}/mkspecs/devices/linux-imx6-g++/qeglfshooks_imx6.cpp ${S}/mkspecs/linux-oe-g++/ | 60 | cp ${S}/mkspecs/devices/linux-imx6-g++/qeglfshooks_imx6.cpp ${S}/mkspecs/linux-oe-g++/ |
45 | else | 61 | else |