summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/gpu-viv-g2d/gpu-viv-g2d.inc43
-rw-r--r--recipes-graphics/gpu-viv-g2d/gpu-viv-g2d_3.5.7-1.0.0.bb9
2 files changed, 52 insertions, 0 deletions
diff --git a/recipes-graphics/gpu-viv-g2d/gpu-viv-g2d.inc b/recipes-graphics/gpu-viv-g2d/gpu-viv-g2d.inc
new file mode 100644
index 0000000..a6b7a5e
--- /dev/null
+++ b/recipes-graphics/gpu-viv-g2d/gpu-viv-g2d.inc
@@ -0,0 +1,43 @@
1# Copyright (C) 2013 Freescale Semiconductor
2
3DESCRIPTION = "GPU Vivante G2D library and sample applications for imx6"
4SECTION = "libs"
5LICENSE = "Proprietary"
6PROVIDES += "virtual/libg2d"
7
8inherit fsl-eula-unpack
9
10PE = "1"
11
12SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
13
14PACKAGES = "gpu-viv-g2d gpu-viv-g2d-dev gpu-viv-g2d-dbg"
15
16# Inhibit warnings about files being stripped.
17INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
18
19S = "${WORKDIR}/${PN}-${PV}"
20
21do_install () {
22 install -d ${D}${libdir}
23 install -d ${D}${includedir}
24
25 cp ${S}/usr/lib/*.so ${D}${libdir}
26 cp -axr ${S}/usr/include/* ${D}${includedir}
27 cp -axr ${S}/opt ${D}
28
29 find ${D}${libdir} -type f -exec chmod 644 {} \;
30 find ${D}${includedir} -type f -exec chmod 644 {} \;
31}
32
33# FIXME: The provided binary doesn't provide soname. If in future BSP
34# release the libraries are fixed, we can drop this hack.
35REALSOLIBS := "${SOLIBS}"
36SOLIBS = "${SOLIBSDEV}"
37
38FILES_${PN} = "/opt ${libdir}/libg2d${SOLIBS} "
39FILES_${PN}-dev = "${includedir}"
40FILES_${PN}-dbg = "${libdir}/.debug/libg2d${SOLIBS}"
41
42PACKAGE_ARCH = "${MACHINE_ARCH}"
43COMPATIBLE_MACHINE = "(mx6)"
diff --git a/recipes-graphics/gpu-viv-g2d/gpu-viv-g2d_3.5.7-1.0.0.bb b/recipes-graphics/gpu-viv-g2d/gpu-viv-g2d_3.5.7-1.0.0.bb
new file mode 100644
index 0000000..349cb2e
--- /dev/null
+++ b/recipes-graphics/gpu-viv-g2d/gpu-viv-g2d_3.5.7-1.0.0.bb
@@ -0,0 +1,9 @@
1# Copyright (C) 2013 Freescale Semiconductor
2
3include gpu-viv-g2d.inc
4
5LIC_FILES_CHKSUM = "file://usr/include/g2d.h;endline=7;md5=861ebad4adc7236f8d1905338abd7eb2"
6
7SRC_URI[md5sum] = "cb1939d1de300bbe334e6e8e0137ae57"
8SRC_URI[sha256sum] = "460d0df171766edbea1fe6781a38346596ad13f748eb971296c04c261cec5450"
9