summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/mesa/mesa_%.bbappend12
1 files changed, 11 insertions, 1 deletions
diff --git a/recipes-graphics/mesa/mesa_%.bbappend b/recipes-graphics/mesa/mesa_%.bbappend
index 6cc7de7..4904a0b 100644
--- a/recipes-graphics/mesa/mesa_%.bbappend
+++ b/recipes-graphics/mesa/mesa_%.bbappend
@@ -18,10 +18,20 @@ USE_VIV_LIBGL_mx6q = "yes"
18USE_VIV_LIBGL_mx6dl = "yes" 18USE_VIV_LIBGL_mx6dl = "yes"
19USE_VIV_LIBGL_mx6sx = "yes" 19USE_VIV_LIBGL_mx6sx = "yes"
20 20
21# FIXME: mesa should support 'x11-no-tls' option
22python () {
23 overrides = d.getVar("OVERRIDES", True).split(":")
24 if "mx6" not in overrides:
25 return
26
27 extra_oeconf = d.getVar("EXTRA_OECONF", True)
28 extra_oeconf = extra_oeconf.replace("--enable-glx-tls", "--enable-glx")
29 d.setVar("EXTRA_OECONF", extra_oeconf)
30}
31
21# FIXME: Dirty hack to allow use of Vivante GPU libGL binary 32# FIXME: Dirty hack to allow use of Vivante GPU libGL binary
22do_install_append_mx6 () { 33do_install_append_mx6 () {
23 if [ "${USE_VIV_LIBGL}" = "yes" ]; then 34 if [ "${USE_VIV_LIBGL}" = "yes" ]; then
24 rm -f ${D}${libdir}/libGL.* 35 rm -f ${D}${libdir}/libGL.*
25 fi 36 fi
26} 37}
27EXTRA_OECONF_mx6 := "${@'${EXTRA_OECONF}'.replace('--enable-glx-tls','--enable-glx')}"