summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/directfb/directfb/bashism.patch18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-graphics/directfb/directfb/bashism.patch b/recipes-graphics/directfb/directfb/bashism.patch
new file mode 100644
index 0000000..2ef4e93
--- /dev/null
+++ b/recipes-graphics/directfb/directfb/bashism.patch
@@ -0,0 +1,18 @@
1${x//y/} is a bash syntax. Replace with something dash compatible
2
3RP 2015/5/3
4Upstream-Status: Pending
5
6Index: DirectFB-1.7.7/configure.in
7===================================================================
8--- DirectFB-1.7.7.orig/configure.in
9+++ DirectFB-1.7.7/configure.in
10@@ -2696,7 +2696,7 @@ AM_CONDITIONAL(BUILD_TOOLS, test "$with_
11 AM_CONDITIONAL(CROSS_COMPILING, test "$cross_compiling" = "yes")
12
13 CFLAGS="$CFLAGS $DFB_INTERNAL_CFLAGS"
14-CXXFLAGS="$CXXFLAGS ${CFLAGS//-Werror-implicit-function-declaration/}"
15+CXXFLAGS="$CXXFLAGS $(printf '%s\n' "$CFLAGS" | sed 's/-Werror-implicit-function-declaration//g')"
16 DFB_LDFLAGS="$LDFLAGS $ZLIB_LIBS"
17
18 CFLAGS="$CFLAGS $CFLAGS_STD"