summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/mesa/mesa-dri_9.0.2.bbappend41
1 files changed, 36 insertions, 5 deletions
diff --git a/recipes-graphics/mesa/mesa-dri_9.0.2.bbappend b/recipes-graphics/mesa/mesa-dri_9.0.2.bbappend
index 74738ff..fe7685a 100644
--- a/recipes-graphics/mesa/mesa-dri_9.0.2.bbappend
+++ b/recipes-graphics/mesa/mesa-dri_9.0.2.bbappend
@@ -1,7 +1,38 @@
1PRINC := "${@int(PRINC) + 1}" 1PRINC := "${@int(PRINC) + 3}"
2 2
3PROVIDES_mx5 = "virtual/libgl" 3# FIXME: We may need to disable EGL, GL ES1 and GL ES2
4PROVIDES_mx6 = "virtual/libgl" 4python __anonymous () {
5 import re
5 6
6PACKAGE_ARCH_mx5 = "${MACHINE_ARCH}" 7 # SoC families to work on
7PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}" 8 families = ['mx5', 'mx6']
9 cur_soc_families = d.getVar('SOC_FAMILY', True)
10 if cur_soc_families and \
11 any(map(lambda x: x in cur_soc_families.split(':'), families)):
12 # Remove egl gles1 and gles2 configure options
13 extra_oeconf = d.getVar('EXTRA_OECONF', True).split()
14 take_out = ['--enable-egl', '--enable-gles1', '--enable-gles2']
15 put_in = ['--disable-egl', '--disable-gles1', '--disable-gles2']
16 pattern = re.compile("--with-egl-platforms")
17 new_extra_oeconf = []
18 for i in extra_oeconf:
19 if i not in take_out and not pattern.match(i):
20 new_extra_oeconf.append(i)
21 for i in put_in:
22 new_extra_oeconf.append(i)
23
24 d.setVar('EXTRA_OECONF', ' '.join(new_extra_oeconf))
25
26 # Remove itens from provides
27 provides = d.getVar('PROVIDES', True)
28 take_out = ['virtual/libgles1', 'virtual/libgles2', 'virtual/egl']
29 new_provides = []
30 for i in provides:
31 if i not in take_out:
32 new_provides.append(i)
33
34 d.setVar('PROVIDES', ' '.join(new_provides))
35
36 # We are now machine specific
37 d.setVar('PACKAGE_ARCH', d.getVar('MACHINE_ARCH'))
38}