summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorRogerio Pimentel <rogerio.pimentel@freescale.com>2012-07-02 09:03:14 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2012-07-02 14:40:16 -0300
commit97a097660aa1ec9ea1b95fafa45a19227a64a47c (patch)
tree81d69ef441d51457bc81bf3fca41e446f1ab9c0a /recipes-qt
parent2cb51eecdede10a8707328f32cfce61e676bb05a (diff)
downloadmeta-fsl-arm-97a097660aa1ec9ea1b95fafa45a19227a64a47c.tar.gz
QT4.7.4 codec patch: Fix to work on X11
This patch fixes the patch that makes phonon works with Freescale codecs and X11 Signed-off-by: Rogerio Pimentel <rogerio.pimentel@freescale.com>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt4/qt4-embedded_4.7.4.bbappend2
-rw-r--r--recipes-qt/qt4/qt4/0001-Add-support-for-i.MX-codecs-to-phonon.patch2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-qt/qt4/qt4-embedded_4.7.4.bbappend b/recipes-qt/qt4/qt4-embedded_4.7.4.bbappend
index cebb203..70d890f 100644
--- a/recipes-qt/qt4/qt4-embedded_4.7.4.bbappend
+++ b/recipes-qt/qt4/qt4-embedded_4.7.4.bbappend
@@ -7,4 +7,4 @@ SRC_URI_append_mx6 += "file://0001-Add-support-for-i.MX-codecs-to-phonon.patch"
7PACKAGE_ARCH_mx5 = "${MACHINE_ARCH}" 7PACKAGE_ARCH_mx5 = "${MACHINE_ARCH}"
8PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}" 8PACKAGE_ARCH_mx6 = "${MACHINE_ARCH}"
9 9
10PRINC := "${@int(PRINC) + 1}" 10PRINC := "${@int(PRINC) + 2}"
diff --git a/recipes-qt/qt4/qt4/0001-Add-support-for-i.MX-codecs-to-phonon.patch b/recipes-qt/qt4/qt4/0001-Add-support-for-i.MX-codecs-to-phonon.patch
index c8c12e0..077939b 100644
--- a/recipes-qt/qt4/qt4/0001-Add-support-for-i.MX-codecs-to-phonon.patch
+++ b/recipes-qt/qt4/qt4/0001-Add-support-for-i.MX-codecs-to-phonon.patch
@@ -25,7 +25,7 @@ index 10a2822..4901530 100644
25 virtual bool eventFilter(QEvent *) = 0; 25 virtual bool eventFilter(QEvent *) = 0;
26 virtual void handlePaint(QPaintEvent *) {} 26 virtual void handlePaint(QPaintEvent *) {}
27 virtual bool paintsOnWidget() { return true; } // Controls overlays 27 virtual bool paintsOnWidget() { return true; } // Controls overlays
28+ virtual void handleMove(QMoveEvent * event ) = 0; 28+ virtual void handleMove(QMoveEvent * event ) {};
29 29
30 protected: 30 protected:
31 VideoWidget *m_videoWidget; 31 VideoWidget *m_videoWidget;