summaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorJavier Viguera <javier.viguera@digi.com>2014-03-05 18:52:18 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2014-03-07 11:37:36 -0300
commitf5922d62ce27f4cc0aa5834aa22f25d8bddba6b4 (patch)
treeb0ab4160aa430ae4c714787d863eb422e48964ad /recipes-qt
parent439826d6aa2c68f5f8b379fdc50a68033a06b44f (diff)
downloadmeta-fsl-arm-f5922d62ce27f4cc0aa5834aa22f25d8bddba6b4.tar.gz
qt4-x11-free: workaround QT/EGL mismatch for MX6
Fix following error: Warning: EGL suggested using X Visual ID 33 (ARGB0888) for EGL config 28 (ARGB0444), but this is incompatable Unable to find an X11 visual which matches EGL config 28 Change-Id: I4b122fdf88a8ddbb54b109587e8c0482311d4cd2 Signed-off-by: Javier Viguera <javier.viguera@digi.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/qt4/qt4-x11-free_4.8.5.bbappend2
-rw-r--r--recipes-qt/qt4/qt4/0003-i.MX6-force-egl-visual-ID-33.patch35
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-qt/qt4/qt4-x11-free_4.8.5.bbappend b/recipes-qt/qt4/qt4-x11-free_4.8.5.bbappend
index 7090bed..cf763b6 100644
--- a/recipes-qt/qt4/qt4-x11-free_4.8.5.bbappend
+++ b/recipes-qt/qt4/qt4-x11-free_4.8.5.bbappend
@@ -11,3 +11,5 @@ QT_CONFIG_FLAGS_append_mx6 = " -I${STAGING_KERNEL_DIR}/include/uapi \
11 -I${STAGING_KERNEL_DIR}/include/ \ 11 -I${STAGING_KERNEL_DIR}/include/ \
12 -DLINUX=1 -DEGL_API_FB=1 \ 12 -DLINUX=1 -DEGL_API_FB=1 \
13 -DQT_QPA_EXPERIMENTAL_TOUCHEVENT=1" 13 -DQT_QPA_EXPERIMENTAL_TOUCHEVENT=1"
14
15SRC_URI_append_mx6 = " file://0003-i.MX6-force-egl-visual-ID-33.patch"
diff --git a/recipes-qt/qt4/qt4/0003-i.MX6-force-egl-visual-ID-33.patch b/recipes-qt/qt4/qt4/0003-i.MX6-force-egl-visual-ID-33.patch
new file mode 100644
index 0000000..9aa158d
--- /dev/null
+++ b/recipes-qt/qt4/qt4/0003-i.MX6-force-egl-visual-ID-33.patch
@@ -0,0 +1,35 @@
1From: Javier Viguera <javier.viguera@digi.com>
2Date: Mon, 3 Mar 2014 17:10:41 +0100
3Subject: [PATCH] i.MX6: force egl visual ID 33
4
5Workaround mismatch between EGL binary libraries and QT for FSL MX6
6based platforms.
7
8Error:
9Warning: EGL suggested using X Visual ID 33 (ARGB0888) for EGL config 28 (ARGB0444), but this is incompatable
10Unable to find an X11 visual which matches EGL config 28
11
12Patch adapted from:
13
14http://wiki.wandboard.org/index.php/Integrate_Qt5_into_yocto_sato_image_on_Wandboard
15
16Upstream-Status: Inappropriate [workaround]
17
18Signed-off-by: Javier Viguera <javier.viguera@digi.com>
19---
20 src/gui/egl/qegl_x11.cpp | 2 +-
21 1 file changed, 1 insertion(+), 1 deletion(-)
22
23diff --git a/src/gui/egl/qegl_x11.cpp b/src/gui/egl/qegl_x11.cpp
24index 196d0f77bf2d..8acf5a6c99d4 100644
25--- a/src/gui/egl/qegl_x11.cpp
26+++ b/src/gui/egl/qegl_x11.cpp
27@@ -319,7 +319,7 @@ VisualID QEgl::getCompatibleVisualId(EGLConfig config)
28 }
29
30 qWarning("Unable to find an X11 visual which matches EGL config %d", configId);
31- return (VisualID)0;
32+ return (VisualID)33;
33 }
34
35 void qt_set_winid_on_widget(QWidget* w, Qt::HANDLE id)