summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorWang Zidan <b50113@freescale.com>2014-09-03 18:07:59 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2014-11-10 18:55:23 -0200
commitda3d8263f195be3fb484342b2c49678cde3a71ea (patch)
tree88794a23a1f58cead0ee0ff9dc13edd310e2022e /recipes-multimedia
parent29c67b0f30ad3339c7d534ec8438c2d40b6685b7 (diff)
downloadmeta-fsl-arm-da3d8263f195be3fb484342b2c49678cde3a71ea.tar.gz
gst1.0-fsl-plugin: Add Freescale Gstreamer1.0 Plugins for MX6
Add Freescale Gstreamer1.0 plugins. - Support Audio/Video local playback - Support HTTP/RTSP Streaming playback - Support RTP/UDP MPEGTS Streaming - Support RTSP Streaming Server Signed-off-by: Zidan Wang <b50113@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.1.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.1.bb b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.1.bb
new file mode 100644
index 0000000..6a44978
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gst1.0-fsl-plugin_4.0.1.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2014 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require gst-fsl-plugin.inc
5
6SRC_URI = "${FSL_MIRROR}/gst1.0-fsl-plugins-${PV}.tar.gz"
7S = "${WORKDIR}/gst1.0-fsl-plugins-${PV}"
8
9EXTRA_OECONF += " CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR}"
10
11SRC_URI[md5sum] = "38d20aa22910a841593318aa638fb702"
12SRC_URI[sha256sum] = "972babc09f53fb0139a350c5b4267101793fcb96d289c4ae402d6a6ddddbe085"
13
14DEPENDS_append = " gstreamer1.0 gstreamer1.0-plugins-base"
15
16PACKAGECONFIG ?= "overlaysink"
17# FIXME: Add all features
18# feature from excluded mm packages
19PACKAGECONFIG[ac3] += ",,libfslac3codec,libfslac3codec"
20# feature from special mm packages
21PACKAGECONFIG[aacp] += ",,libfslaacpcodec,libfslaacpcodec"
22MSDEPENDS = "libfslmsparser libfslmscodec"
23PACKAGECONFIG[wma10dec] += ",,${MSDEPENDS},${MSDEPENDS}"
24PACKAGECONFIG[wma8enc] += "--enable-wma8enc,--disable-wma8enc,${MSDEPENDS},${MSDEPENDS}"
25PACKAGECONFIG[overlaysink] += "--enable-overlaysink,--disable-overlaysink,gpu-viv-g2d"
26
27FILES_${PN} = "${libdir}/gstreamer-1.0/*.so ${datadir}"
28FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
29FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la ${libdir}/pkgconfig/*.pc"
30FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
31FILES_${PN}-gplay = "${bindir}/gplay-1.0"
32FILES_${PN}-libgplaycore = "${libdir}/libgplaycore-1.0${SOLIBS}"
33FILES_${PN}-libgstfsl = "${libdir}/libgstfsl-1.0${SOLIBS}"
34
35COMPATIBLE_MACHINE = "(mx6)"