summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorDaiane Angolini <daiane.angolini@freescale.com>2013-05-17 18:06:10 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2013-05-28 11:00:50 -0300
commitbe6317c244c61a62b952bbf9b5b706c239f49a78 (patch)
tree5a8664d06bbb2a4158dd033b44fc9d9187b596d2 /recipes-multimedia
parent11bb6662461b274dd7570d0c544593bf9b6bd938 (diff)
downloadmeta-fsl-arm-be6317c244c61a62b952bbf9b5b706c239f49a78.tar.gz
fsl-mm-core: Remove old multimedia packages for MX5
Remove fsl-mm-codeclib, fsl-mm-codeclib, fsl-mm-flv-codeclib and fsl-mm-mp3enc-codeclib. In new version, all packages are covered by only libfslcodec Change-Id: If7c8eaaad5e493410e968911734eb00a35711ff7 Signed-off-by: Daiane Angolini <daiane.angolini@freescale.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/fsl-mm-core/fsl-mm-codeclib.inc31
-rw-r--r--recipes-multimedia/fsl-mm-core/fsl-mm-codeclib_2.0.3.bb35
-rw-r--r--recipes-multimedia/fsl-mm-core/fsl-mm-flv-codeclib_2.0.3.bb22
-rw-r--r--recipes-multimedia/fsl-mm-core/fsl-mm-mp3enc-codeclib_2.0.3.bb18
4 files changed, 0 insertions, 106 deletions
diff --git a/recipes-multimedia/fsl-mm-core/fsl-mm-codeclib.inc b/recipes-multimedia/fsl-mm-core/fsl-mm-codeclib.inc
deleted file mode 100644
index fedc022..0000000
--- a/recipes-multimedia/fsl-mm-core/fsl-mm-codeclib.inc
+++ /dev/null
@@ -1,31 +0,0 @@
1# Copyright (C) 2011-2013 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Freescale Multimedia codec libs"
5LICENSE = "Proprietary"
6SECTION = "multimedia"
7
8INC_PR = "r4"
9
10SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
11
12inherit fsl-eula-unpack pkgconfig
13
14# FIXME: Quiet down the warnings during package
15INSANE_SKIP_${PN} = "ldflags textrel"
16INSANE_SKIP_${PN}-dev = "ldflags textrel"
17
18do_install () {
19 install -d ${D}${includedir} ${D}${libdir}
20 cp -ar ${S}/release/lib/* ${D}${libdir}
21 rm -rf ${D}${includedir}/mm_ghdr
22 cp -r ${S}/ghdr* ${D}${includedir}
23 mv ${D}${includedir}/ghdr ${D}${includedir}/mm_ghdr
24
25 # FIXME: Fix permissions
26 find ${D} -type f -exec chmod 0644 '{}' ';'
27}
28
29FILES_${PN} += "${libdir}/lib*_elinux.3.0.1.07.00"
30
31PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-multimedia/fsl-mm-core/fsl-mm-codeclib_2.0.3.bb b/recipes-multimedia/fsl-mm-core/fsl-mm-codeclib_2.0.3.bb
deleted file mode 100644
index 42cf136..0000000
--- a/recipes-multimedia/fsl-mm-core/fsl-mm-codeclib_2.0.3.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1include fsl-mm-codeclib.inc
2
3PR = "${INC_PR}.0"
4
5LIC_FILES_CHKSUM = "file://docs/EULA.txt;md5=ea4d5c069d7aef0838a110409ea78a01"
6
7SRC_URI[md5sum] = "9ee06c147f635d1f904d53fc193150cc"
8SRC_URI[sha256sum] = "427436c0ab7795204a23150bac19cf261a88693e9acd9d3eab5c06c60ffe55bd"
9
10do_install_append() {
11 # FIXME: Same pkgconfig file is provided in every source package
12 # so we install it just here and all other packages need to
13 # depends on fsl-mm-codeclib-dev explicitly.
14 install -d ${D}${libdir}/pkgconfig
15 install -m 0644 ${S}/pkgconfig/fsl-mm-core.pc ${D}${libdir}/pkgconfig
16}
17
18# FIXME: Install files which has no sonames
19PACKAGES = "${PN} ${PN}-dev"
20FILES_${PN} += " \
21 ${libdir}/lib_aac_parser_arm11_elinux.so \
22 ${libdir}/lib_bmp_dec_arm11_elinux.so \
23 ${libdir}/lib_deinterlace_arm11_elinux.so \
24 ${libdir}/lib_flac_parser_arm11_elinux.so \
25 ${libdir}/lib_gif_dec_arm11_elinux.so \
26 ${libdir}/lib_id3_parser_arm11_elinux.so \
27 ${libdir}/lib_jpeg_enc_arm11_elinux.so \
28 ${libdir}/lib_mp3_parser_v2_arm11_elinux.so \
29 ${libdir}/lib_png_dec_arm11_elinux.so \
30 ${libdir}/lib_src_ppp_arm11_elinux.so \
31 ${libdir}/lib_wav_parser_arm11_elinux.so \
32 ${libdir}/libmpeg4_encoder_arm11_ELINUX.so \
33"
34
35COMPATIBLE_MACHINE = "(mx5)"
diff --git a/recipes-multimedia/fsl-mm-core/fsl-mm-flv-codeclib_2.0.3.bb b/recipes-multimedia/fsl-mm-core/fsl-mm-flv-codeclib_2.0.3.bb
deleted file mode 100644
index 75e07f5..0000000
--- a/recipes-multimedia/fsl-mm-core/fsl-mm-flv-codeclib_2.0.3.bb
+++ /dev/null
@@ -1,22 +0,0 @@
1# Copyright (C) 2011-2013 Freescale Semicondutors <aalonso@freescale.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4include fsl-mm-codeclib.inc
5
6PR = "${INC_PR}.0"
7LIC_FILES_CHKSUM = "file://ghdr/common/fsl_types.h;endline=13;md5=b805ce4a390c94d002ef86bd15ceafd4"
8
9SRC_URI[md5sum] = "b0244d881f73557be9221e6534c239be"
10SRC_URI[sha256sum] = "737399c76e8b991ebb76c07599b83da6a185211d88b95d9a9b4245f6d7fccec2"
11
12do_install_append() {
13 # FIXME: Those files are deployed in fsl-mm-codeclib
14 rm -r ${D}${includedir}/mm_ghdr/common
15}
16
17# FIXME: Same pkgconfig file is provided in every source so we need to
18# depends on 'fsl-mm-codeclib-dev' explicitly as it is
19# installed just on it.
20RDEPENDS_${PN}-dev = "fsl-mm-codeclib-dev"
21
22COMPATIBLE_MACHINE = "(mx5)"
diff --git a/recipes-multimedia/fsl-mm-core/fsl-mm-mp3enc-codeclib_2.0.3.bb b/recipes-multimedia/fsl-mm-core/fsl-mm-mp3enc-codeclib_2.0.3.bb
deleted file mode 100644
index eb781cf..0000000
--- a/recipes-multimedia/fsl-mm-core/fsl-mm-mp3enc-codeclib_2.0.3.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1# Copyright (C) 2011-2013 Freescale Semicondutors <aalonso@freescale.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4include fsl-mm-codeclib.inc
5
6PR = "${INC_PR}.0"
7
8LIC_FILES_CHKSUM = "file://ghdr/mp3_enc_interface.h;endline=11;md5=545a1927139b4739d8980c49954b6b95"
9
10SRC_URI[md5sum] = "049611d9f76b524b9fa9521527ba3235"
11SRC_URI[sha256sum] = "e3712fa45a8f42617773678d45ab7ae0f20150a4d904f1e73afa8baa1941cf99"
12
13# FIXME: Same pkgconfig file is provided in every source so we need to
14# depends on 'fsl-mm-codeclib-dev' explicitly as it is
15# installed just on it.
16RDEPENDS_${PN}-dev += "fsl-mm-codeclib-dev"
17
18COMPATIBLE_MACHINE = "(mx5)"