summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorNeena Busireddy <neena.busireddy@freescale.com>2014-10-16 15:45:05 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2014-10-23 19:57:41 -0200
commit82e00750af48747ed5da8315b524ca0f8f9283ba (patch)
tree75ec9844a20f759ee0c6d0eb8adcf9134f144f08 /recipes-multimedia
parent8e65d3798f5791d0e7e77ef3393c479f12167baf (diff)
downloadmeta-fsl-arm-82e00750af48747ed5da8315b524ca0f8f9283ba.tar.gz
gstreamer1.0-plugins-bad: Remove gles2 for i.MX6 SoloLite
i.MX6 SoloLite (mx6sl) does not support 3D GPU hardware acceleration. The X11 backend only supports mesa software rendering GL and non-x11 backends does not support both GL and GLES. This patch defines PACKAGECONFIG_GL for each i.MX6 SoC family as i.MX6 SoloLite is different from other SoC's. Signed-off-by: Neena Busireddy <neena.busireddy@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
index 8be11a2..da90235 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -5,3 +5,9 @@ CFLAGS_append_mx6 = " -DLINUX \
5 base_contains('DISTRO_FEATURES', 'wayland', '-DEGL_API_FB -DEGL_API_WL', \ 5 base_contains('DISTRO_FEATURES', 'wayland', '-DEGL_API_FB -DEGL_API_WL', \
6 base_contains('DISTRO_FEATURES', 'directfb', '-DEGL_API_DFB', \ 6 base_contains('DISTRO_FEATURES', 'directfb', '-DEGL_API_DFB', \
7 '-DEGL_API_FB', d),d),d)}" 7 '-DEGL_API_FB', d),d),d)}"
8
9PACKAGECONFIG_GL_mx6q = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
10PACKAGECONFIG_GL_mx6dl = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
11PACKAGECONFIG_GL_mx6sl = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', \
12 base_contains('DISTRO_FEATURES', 'x11', \
13 'opengl', '', d), '', d)}"