summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorWang Zidan <b50113@freescale.com>2014-09-03 18:08:00 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2014-11-10 18:55:23 -0200
commit5232c4cb4f33df1298065795c0966ba0a8df7fbe (patch)
tree1513dc4afead0043462d9f7b3835593bd9b8bf99 /recipes-multimedia
parentda3d8263f195be3fb484342b2c49678cde3a71ea (diff)
downloadmeta-fsl-arm-5232c4cb4f33df1298065795c0966ba0a8df7fbe.tar.gz
libfslvpuwrap: Upgrade from version 1.0.46 to 1.0.54
Remove the IOVirtmem patch since it has been merged into version 1.0.54. libfslvpuwrap upgrade to version 1.0.54. Changes about version 1.0.54: - Include some bug fix. - Enhance the robust in avcc conversion operation for corrupted clips. - Add api to query the available frame buffer number in decoder code refine. - Add config for intra refresh mode: VPU_ENC_CONF_INTRA_REFRESH_MODE. - Change deblock related parameter to improve encode quality. - Config stuff padding(disable) for mjpeg encoder. - Add some parameters for unit test, include gamma, initialdelay, refreshratio, refreshmode. - Add support for nal_size_length is equal to 1 or 2. - Modify the checking of return value from IOGetVirtMem. - For corrupted clip with only one frame, vpu report error instead of eos. - Add detecting of resoluton change(bit20). Signed-off-by: Zidan Wang <b50113@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/libfslvpuwrap/libfslvpuwrap/0001-vpu_wrapper-fix-tests-of-return-value-from-IOGetVirt.patch41
-rw-r--r--recipes-multimedia/libfslvpuwrap/libfslvpuwrap_1.0.54.bb (renamed from recipes-multimedia/libfslvpuwrap/libfslvpuwrap_1.0.46.bb)6
2 files changed, 3 insertions, 44 deletions
diff --git a/recipes-multimedia/libfslvpuwrap/libfslvpuwrap/0001-vpu_wrapper-fix-tests-of-return-value-from-IOGetVirt.patch b/recipes-multimedia/libfslvpuwrap/libfslvpuwrap/0001-vpu_wrapper-fix-tests-of-return-value-from-IOGetVirt.patch
deleted file mode 100644
index ccd2d9e..0000000
--- a/recipes-multimedia/libfslvpuwrap/libfslvpuwrap/0001-vpu_wrapper-fix-tests-of-return-value-from-IOGetVirt.patch
+++ /dev/null
@@ -1,41 +0,0 @@
1From 7ca66c10c05168c7d342df7c7a70d4a1ae0629f7 Mon Sep 17 00:00:00 2001
2From: Eric Nelson <eric.nelson@boundarydevices.com>
3Date: Sat, 28 Jun 2014 09:45:09 -0700
4Subject: [PATCH] vpu_wrapper: fix tests of return value from IOGetVirtMem
5
6IOGetVirtMem() returns a pointer or specifically -1 (MAP_FAILED)
7in the case of failure.
8
9Upstream-Status: Pending
10
11Signed-off-by: Laci Tele <laci@boundarydevices.com>
12Signed-off-by: Eric Nelson <eric.nelson@boundarydevices.com>
13---
14 vpu_wrapper.c | 4 ++--
15 1 file changed, 2 insertions(+), 2 deletions(-)
16
17diff --git a/vpu_wrapper.c b/vpu_wrapper.c
18index 9249174..148c5df 100755
19--- a/vpu_wrapper.c
20+++ b/vpu_wrapper.c
21@@ -6653,7 +6653,7 @@ VpuDecRetCode VPU_DecGetMem(VpuMemDesc* pInOutMem)
22 return VPU_DEC_RET_FAILURE;
23 }
24 ret=IOGetVirtMem(&buff);
25- if(ret==0) //if(ret!=RETCODE_SUCCESS)
26+ if(ret == -1) //if(ret==MAP_FAILED)
27 {
28 VPU_ERROR("%s: get virtual memory failure: size=%d, ret=%d \r\n",__FUNCTION__,buff.size,ret);
29 return VPU_DEC_RET_FAILURE;
30@@ -8277,7 +8277,7 @@ VpuEncRetCode VPU_EncGetMem(VpuMemDesc* pInOutMem)
31 return VPU_ENC_RET_FAILURE;
32 }
33 ret=IOGetVirtMem(&buff);
34- if(ret==0) //if(ret!=RETCODE_SUCCESS)
35+ if(ret == -1) //if(ret==MAP_FAILED)
36 {
37 VPU_ENC_ERROR("%s: get virtual memory failure: size=%d, ret=%d \r\n",__FUNCTION__,buff.size,(UINT32)ret);
38 return VPU_ENC_RET_FAILURE;
39--
401.9.1
41
diff --git a/recipes-multimedia/libfslvpuwrap/libfslvpuwrap_1.0.46.bb b/recipes-multimedia/libfslvpuwrap/libfslvpuwrap_1.0.54.bb
index 8cc1523..008911e 100644
--- a/recipes-multimedia/libfslvpuwrap/libfslvpuwrap_1.0.46.bb
+++ b/recipes-multimedia/libfslvpuwrap/libfslvpuwrap_1.0.54.bb
@@ -7,10 +7,10 @@ SECTION = "multimedia"
7LIC_FILES_CHKSUM = "file://EULA.txt;md5=93b784b1c11b3fffb1638498a8dde3f6" 7LIC_FILES_CHKSUM = "file://EULA.txt;md5=93b784b1c11b3fffb1638498a8dde3f6"
8 8
9SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true" 9SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
10SRC_URI[md5sum] = "1f50110cb6de8ebf767fb9c5f8baf20d" 10S = "${WORKDIR}/${PN}-${PV}"
11SRC_URI[sha256sum] = "7fc1258de338339d19a1a35167393fdc4d773682dfd9b951b197403a075f85fd"
12 11
13SRC_URI_append = " file://0001-vpu_wrapper-fix-tests-of-return-value-from-IOGetVirt.patch" 12SRC_URI[md5sum] = "b07a2d4e7bf44225353106ed209f6dac"
13SRC_URI[sha256sum] = "eef2cc0c65d96d3a0f75d7134eef8ef0099ece2502d093fc13739edcb343e1dd"
14 14
15inherit fsl-eula-unpack autotools pkgconfig 15inherit fsl-eula-unpack autotools pkgconfig
16 16