summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-11-19 05:06:40 -0600
committerOtavio Salvador <otavio@ossystems.com.br>2012-12-03 09:25:07 -0200
commit42b230b8c45daa958829672ab346e5aef53fa1dd (patch)
treef92cdb2fbd16b94140ddd2ac5adda8c28a3ca71a /recipes-multimedia
parent9db999519e05a001d6b31acc817a4ee09bea15c5 (diff)
downloadmeta-fsl-arm-42b230b8c45daa958829672ab346e5aef53fa1dd.tar.gz
libfslparser: Drop the package split as gst-fsl-plugin dlopen them
As gst-fsl-plugin dlopen the parser libraries and shlibs won't work in this case for automatically discover the dependencies so we package all parsers together for now. Change-Id: I8e86c65dcac631d74d5a795f5268f8e807fd2543 Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/libfslparser/libfslparser_3.0.1.bb20
1 files changed, 6 insertions, 14 deletions
diff --git a/recipes-multimedia/libfslparser/libfslparser_3.0.1.bb b/recipes-multimedia/libfslparser/libfslparser_3.0.1.bb
index 4276784..993569e 100644
--- a/recipes-multimedia/libfslparser/libfslparser_3.0.1.bb
+++ b/recipes-multimedia/libfslparser/libfslparser_3.0.1.bb
@@ -5,37 +5,29 @@ LICENSE = "Proprietary"
5SECTION = "multimedia" 5SECTION = "multimedia"
6LIC_FILES_CHKSUM = "file://EULA.txt;md5=ea4d5c069d7aef0838a110409ea78a01" 6LIC_FILES_CHKSUM = "file://EULA.txt;md5=ea4d5c069d7aef0838a110409ea78a01"
7 7
8PR = "r1"
9
8inherit fsl-eula-unpack autotools pkgconfig 10inherit fsl-eula-unpack autotools pkgconfig
9 11
10SRC_URI[md5sum] = "52a72680d4c1db4b9fadcae56980a8ae" 12SRC_URI[md5sum] = "52a72680d4c1db4b9fadcae56980a8ae"
11SRC_URI[sha256sum] = "50b514fe3e9912ac24e9da81de5e713bf42e1a7d3a41ae6f221258c2f8539194" 13SRC_URI[sha256sum] = "50b514fe3e9912ac24e9da81de5e713bf42e1a7d3a41ae6f221258c2f8539194"
12SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true" 14SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
13 15
14PACKAGES_DYNAMIC = "${PN}-*"
15
16do_install_append() { 16do_install_append() {
17 # FIXME: The only parser outside imx-mm/parse is the mp3 so move it 17 # FIXME: The only parser outside imx-mm/parse is the mp3 so move it
18 mv ${D}${libdir}/*mp3* ${D}${libdir}/imx-mm/parser/ 18 mv ${D}${libdir}/*mp3* ${D}${libdir}/imx-mm/parser/
19} 19}
20 20
21python populate_packages_prepend() { 21python populate_packages_prepend() {
22 parserdir = bb.data.expand('${libdir}/imx-mm/parser', d)
23 do_split_packages(d, parserdir, '^lib_(.*)_elinux\.so\.',
24 aux_files_pattern_verbatim='${libdir}/imx-mm/parser/lib_%s_elinux.so.*',
25 output_pattern='libfslparser-%s', recursive=True,
26 description='Freescale IMX Parser (%s)',
27 extra_depends='', prepend=True)
28
29 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have 22 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have
30 # the source we cannot fix it. Disable the insane check for now. 23 # the source we cannot fix it. Disable the insane check for now.
24 # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
31 for p in d.getVar('PACKAGES', True).split(): 25 for p in d.getVar('PACKAGES', True).split():
32 d.setVar("INSANE_SKIP_%s" % p, "ldflags") 26 d.setVar("INSANE_SKIP_%s" % p, "ldflags dev-so")
33} 27}
34 28
35# Ensure we get warnings if we miss something 29# FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
36FILES_${PN} = "" 30FILES_${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}"
37
38FILES_${PN}-dev += "${libdir}/imx-mm/*/*${SOLIBSDEV}"
39 31
40PACKAGE_ARCH = "${MACHINE_ARCH}" 32PACKAGE_ARCH = "${MACHINE_ARCH}"
41COMPATIBLE_MACHINE = "(mx6)" 33COMPATIBLE_MACHINE = "(mx6)"