summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorWang Zidan <b50113@freescale.com>2014-09-12 16:34:13 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2014-09-15 09:28:02 -0300
commit1ed2b27171c4d553cc84655af9a19f50c3084199 (patch)
tree14f1a25406e6f7f39aa3b420bb817f828d48417a /recipes-multimedia
parentccba003438f8bda6cf50675050dbf66e9aec5395 (diff)
downloadmeta-fsl-arm-1ed2b27171c4d553cc84655af9a19f50c3084199.tar.gz
gstreamer1.0-plugins-base: Enable native video in playbin for i.MX SoCs
GST_PLAY_FLAG_NATIVE_VIDEO means link decoder directly with video render, otherwise, software csc/resize/deinterlace plugins will be linked between them. For all i.MX chips, we should enable this flag, as the fsl renders has the capability to do csc/resize. Signed-off-by: Zidan Wang <b50113@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/gstplaybin-enable-native-video.patch31
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend10
2 files changed, 41 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/gstplaybin-enable-native-video.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/gstplaybin-enable-native-video.patch
new file mode 100644
index 0000000..15322bd
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/gstplaybin-enable-native-video.patch
@@ -0,0 +1,31 @@
1From 9cfb86cd100904f0ef2626f348695bd2d3416c6a Mon Sep 17 00:00:00 2001
2From: Jian Li <jian.li@freescale.com>
3Date: Mon, 23 Jun 2014 14:14:07 +0800
4Subject: [PATCH] gstplaybin enable native video
5
6- use native video patch in playbin for i.MX SoCs
7
8Upstream Status: Inappropriate [platform specific]
9
10Signed-off-by: Jian Li <jian.li@freescale.com>
11---
12 gst/playback/gstplaybin2.c | 3 +--
13 1 file changed, 1 insertion(+), 2 deletions(-)
14
15diff --git a/gst/playback/gstplaybin2.c b/gst/playback/gstplaybin2.c
16index fc02ca3..c342438 100644
17--- a/gst/playback/gstplaybin2.c
18+++ b/gst/playback/gstplaybin2.c
19@@ -511,8 +511,7 @@ struct _GstPlayBinClass
20 #define DEFAULT_SUBURI NULL
21 #define DEFAULT_SOURCE NULL
22 #define DEFAULT_FLAGS GST_PLAY_FLAG_AUDIO | GST_PLAY_FLAG_VIDEO | GST_PLAY_FLAG_TEXT | \
23- GST_PLAY_FLAG_SOFT_VOLUME | GST_PLAY_FLAG_DEINTERLACE | \
24- GST_PLAY_FLAG_SOFT_COLORBALANCE
25+ GST_PLAY_FLAG_SOFT_VOLUME | GST_PLAY_FLAG_NATIVE_VIDEO
26 #define DEFAULT_N_VIDEO 0
27 #define DEFAULT_CURRENT_VIDEO -1
28 #define DEFAULT_N_AUDIO 0
29--
301.7.9.5
31
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
new file mode 100644
index 0000000..5b939d4
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_%.bbappend
@@ -0,0 +1,10 @@
1
2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3
4SRC_URI_append_mxs = " file://gstplaybin-enable-native-video.patch"
5SRC_URI_append_mx5 = " file://gstplaybin-enable-native-video.patch"
6SRC_URI_append_mx6 = " file://gstplaybin-enable-native-video.patch"
7
8PACKAGE_ARCH_mxs = "${MACHINE_SOCARCH}"
9PACKAGE_ARCH_mx5 = "${MACHINE_SOCARCH}"
10PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}"