diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2012-05-23 16:04:10 -0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2012-06-04 10:42:45 -0300 |
commit | 4d59191d77c569479748e85ba69b7065038d7fb7 (patch) | |
tree | c3902f2385d893bafeb8cdc0528dbbcaf32fc764 /recipes-multimedia | |
parent | 8bc9df3be0cb33983c3c1b9ceed31c121cbf4c71 (diff) | |
download | meta-fsl-arm-4d59191d77c569479748e85ba69b7065038d7fb7.tar.gz |
fsl-mm-codeclib: move code to a .inc file
This easy reuse of code between i.MX5 and i.MX6 SoC families and
avoiding useless code duplication.
We also fixed the LICENSE field as this is Proprietary licensed.
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r-- | recipes-multimedia/fsl-mm-core/fsl-mm-codeclib.inc | 34 | ||||
-rw-r--r-- | recipes-multimedia/fsl-mm-core/fsl-mm-codeclib_2.0.3.bb | 46 |
2 files changed, 37 insertions, 43 deletions
diff --git a/recipes-multimedia/fsl-mm-core/fsl-mm-codeclib.inc b/recipes-multimedia/fsl-mm-core/fsl-mm-codeclib.inc new file mode 100644 index 0000000..f7990b6 --- /dev/null +++ b/recipes-multimedia/fsl-mm-core/fsl-mm-codeclib.inc | |||
@@ -0,0 +1,34 @@ | |||
1 | # Copyright (C) 2011 Freescale Semiconductor | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | DESCRIPTION = "Freescale mm codec libs" | ||
5 | SECTION = "multimedia" | ||
6 | LICENSE = "Proprietary" | ||
7 | DEPENDS = "pkgconfig" | ||
8 | |||
9 | LIC_FILES_CHKSUM = "file://docs/EULA.txt;md5=ea4d5c069d7aef0838a110409ea78a01" | ||
10 | |||
11 | INC_PR = "r1" | ||
12 | |||
13 | INSANE_SKIP_${PN} = "ldflags" | ||
14 | INSANE_SKIP_${PN}-dev = "ldflags" | ||
15 | |||
16 | SRC_URI = "file://${PN}-${PV}.tar.gz" | ||
17 | |||
18 | do_install () { | ||
19 | install -d ${D}${libdir} | ||
20 | install -d ${D}${libdir}/pkgconfig | ||
21 | install -d ${D}${includedir}/mm_ghdr | ||
22 | |||
23 | cp -r ${S}/release/lib/* ${D}${libdir} | ||
24 | cp -r ${S}/ghdr/* ${D}${includedir}/mm_ghdr | ||
25 | install -m 0644 ${S}/pkgconfig/fsl-mm-core.pc ${D}${libdir}/pkgconfig | ||
26 | |||
27 | # Fix file permissions | ||
28 | find ${D} -type f -exec chmod a-x '{}' ';' | ||
29 | } | ||
30 | |||
31 | FILES_${PN} += "${libdir}/${SOLIBS}" | ||
32 | FILES_${PN}-dev += "${libdir}/${SOLIBSDEV}" | ||
33 | |||
34 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
diff --git a/recipes-multimedia/fsl-mm-core/fsl-mm-codeclib_2.0.3.bb b/recipes-multimedia/fsl-mm-core/fsl-mm-codeclib_2.0.3.bb index cda5500..21720f3 100644 --- a/recipes-multimedia/fsl-mm-core/fsl-mm-codeclib_2.0.3.bb +++ b/recipes-multimedia/fsl-mm-core/fsl-mm-codeclib_2.0.3.bb | |||
@@ -1,48 +1,8 @@ | |||
1 | # Copyright (C) 2011 Freescale Semiconductor | 1 | include fsl-mm-codeclib.inc |
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | 2 | ||
4 | DESCRIPTION = "Freescale mm codec libs" | 3 | PR = "${INC_PR}.0" |
5 | LICENSE = "MIT" | ||
6 | SECTION = "multimedia" | ||
7 | DEPENDS = "pkgconfig" | ||
8 | PR = "r0" | ||
9 | 4 | ||
10 | LIC_FILES_CHKSUM = "file://docs/EULA.txt;md5=ea4d5c069d7aef0838a110409ea78a01" | ||
11 | |||
12 | SRC_URI = "file://${PN}-${PV}.tar.gz" | ||
13 | SRC_URI[md5sum] = "e06bcaae6a7f5162caaa4ae5a56bf067" | 5 | SRC_URI[md5sum] = "e06bcaae6a7f5162caaa4ae5a56bf067" |
14 | SRC_URI[sha256sum] = "5f1ec8200469d886dfbe82a22a63033914dc690c545c74a27ababb24fd53952a" | 6 | SRC_URI[sha256sum] = "5f1ec8200469d886dfbe82a22a63033914dc690c545c74a27ababb24fd53952a" |
15 | 7 | ||
16 | do_install () { | 8 | COMPATIBLE_MACHINE = "(mx5)" |
17 | install -d ${D}${libdir} | ||
18 | install -d ${D}${libdir}/pkgconfig | ||
19 | install -d ${D}${includedir}/mm_ghdr | ||
20 | install -d ${D}${includedir}/mm_ghdr/aac_parser | ||
21 | install -d ${D}${includedir}/mm_ghdr/common | ||
22 | install -d ${D}${includedir}/mm_ghdr/flac_parser | ||
23 | install -d ${D}${includedir}/mm_ghdr/mp3_parser | ||
24 | install -d ${D}${includedir}/mm_ghdr/mp3_parser_v2 | ||
25 | install -d ${D}${includedir}/mm_ghdr/sbc | ||
26 | install -d ${D}${includedir}/mm_ghdr/wav_parser | ||
27 | install -m 0755 ${S}/release/lib/* ${D}${libdir} | ||
28 | install -m 0644 ${S}/pkgconfig/fsl-mm-core.pc ${D}${libdir}/pkgconfig | ||
29 | install -m 0644 ${S}/ghdr/*.h ${D}${includedir}/mm_ghdr | ||
30 | install -m 0644 ${S}/ghdr/aac_parser/*.h ${D}${includedir}/mm_ghdr/aac_parser | ||
31 | install -m 0644 ${S}/ghdr/common/*.h ${D}${includedir}/mm_ghdr/common | ||
32 | install -m 0644 ${S}/ghdr/flac_parser/*.h ${D}${includedir}/mm_ghdr/flac_parser | ||
33 | install -m 0644 ${S}/ghdr/mp3_parser/*.h ${D}${includedir}/mm_ghdr/mp3_parser | ||
34 | install -m 0644 ${S}/ghdr/mp3_parser_v2/*.h ${D}${includedir}/mm_ghdr/mp3_parser_v2 | ||
35 | install -m 0644 ${S}/ghdr/sbc/*.h ${D}${includedir}/mm_ghdr/sbc | ||
36 | install -m 0644 ${S}/ghdr/wav_parser/*.h ${D}${includedir}/mm_ghdr/wav_parser | ||
37 | } | ||
38 | |||
39 | INSANE_SKIP = "True" | ||
40 | FILES_${PN} += "${libdir}/*.so ${libdir}/pkgconfig/*.pc" | ||
41 | FILES_${PN}-dev += "${includedir}/mm_ghdr/*.h \ | ||
42 | ${includedir}/mm_ghdr/aac_parser/*.h \ | ||
43 | ${includedir}/mm_ghdr/common/*.h \ | ||
44 | ${includedir}/mm_ghdr/flac_parser/*.h \ | ||
45 | ${includedir}/mm_ghdr/mp3_parser/*.h \ | ||
46 | ${includedir}/mm_ghdr/mp3_parser2/*.h \ | ||
47 | ${includedir}/mm_ghdr/sbc/*.h \ | ||
48 | ${includedir}/mm_ghdr/wav_parser/*.h" | ||