summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorDaiane Angolini <angolini@gmail.com>2013-04-10 11:26:08 -0300
committerDaiane Angolini <angolini@gmail.com>2013-04-10 14:56:25 -0300
commitdcdc13c97b05e8cfd4fa66bdd4e65c4d06c13832 (patch)
tree561c88485afc1233c498cd4b1b551c587c25fc44 /recipes-multimedia
parent4af3f1cc3d7a13b41115dd8566a7a2c87a3214b8 (diff)
downloadmeta-fsl-arm-dcdc13c97b05e8cfd4fa66bdd4e65c4d06c13832.tar.gz
libfslparser: Add .inc file in order to reuse code
Include libfslcodec.inc file in order to reuse code for future newer versions of this packaged to be added. Change-Id: If75ae84fb13860999716ab34595ef2b0eada5219 Signed-off-by: Daiane Angolini <daiane.angolini@freescale.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/libfslparser/libfslparser.inc26
-rw-r--r--recipes-multimedia/libfslparser/libfslparser_3.0.5.bb20
2 files changed, 29 insertions, 17 deletions
diff --git a/recipes-multimedia/libfslparser/libfslparser.inc b/recipes-multimedia/libfslparser/libfslparser.inc
new file mode 100644
index 0000000..6bfa502
--- /dev/null
+++ b/recipes-multimedia/libfslparser/libfslparser.inc
@@ -0,0 +1,26 @@
1# Copyright (C) 2012-2013 Freescale Semicondutors
2# Released under the MIT license (see COPYING.MIT for the terms)
3DESCRIPTION = "Freescale Multimedia parser libs"
4LICENSE = "Proprietary"
5SECTION = "multimedia"
6LIC_FILES_CHKSUM = "file://EULA.txt;md5=ea4d5c069d7aef0838a110409ea78a01"
7
8INC_PR = "r1"
9
10inherit fsl-eula-unpack autotools pkgconfig
11
12SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
13
14python populate_packages_prepend() {
15 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have
16 # the source we cannot fix it. Disable the insane check for now.
17 # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
18 for p in d.getVar('PACKAGES', True).split():
19 d.setVar("INSANE_SKIP_%s" % p, "ldflags dev-so")
20}
21
22# FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
23FILES_${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}"
24
25PACKAGE_ARCH = "${MACHINE_ARCH}"
26
diff --git a/recipes-multimedia/libfslparser/libfslparser_3.0.5.bb b/recipes-multimedia/libfslparser/libfslparser_3.0.5.bb
index d53805a..d31c34b 100644
--- a/recipes-multimedia/libfslparser/libfslparser_3.0.5.bb
+++ b/recipes-multimedia/libfslparser/libfslparser_3.0.5.bb
@@ -1,28 +1,14 @@
1# Copyright (C) 2012-2013 Freescale Semicondutors 1# Copyright (C) 2012-2013 Freescale Semicondutors
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3DESCRIPTION = "Freescale Multimedia parser libs" 3
4LICENSE = "Proprietary"
5SECTION = "multimedia"
6LIC_FILES_CHKSUM = "file://EULA.txt;md5=ea4d5c069d7aef0838a110409ea78a01" 4LIC_FILES_CHKSUM = "file://EULA.txt;md5=ea4d5c069d7aef0838a110409ea78a01"
7 5
8PR = "r2" 6require libfslparser.inc
9 7
10inherit fsl-eula-unpack autotools pkgconfig 8PR = "${INC_PR}.0"
11 9
12SRC_URI[md5sum] = "9fd8105530e1668ae91bd53a5b0d9807" 10SRC_URI[md5sum] = "9fd8105530e1668ae91bd53a5b0d9807"
13SRC_URI[sha256sum] = "d3139e28e453d2af04439e607cd12ad17e117144049c9a8add05a5a142c654ae" 11SRC_URI[sha256sum] = "d3139e28e453d2af04439e607cd12ad17e117144049c9a8add05a5a142c654ae"
14SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
15
16python populate_packages_prepend() {
17 # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have
18 # the source we cannot fix it. Disable the insane check for now.
19 # FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
20 for p in d.getVar('PACKAGES', True).split():
21 d.setVar("INSANE_SKIP_%s" % p, "ldflags dev-so")
22}
23
24# FIXME: gst-fsl-plugin looks for the .so files so we need to deploy those
25FILES_${PN} += "${libdir}/imx-mm/*/*${SOLIBS} ${libdir}/imx-mm/*/*${SOLIBSDEV}"
26 12
27PACKAGE_ARCH = "${MACHINE_ARCH}" 13PACKAGE_ARCH = "${MACHINE_ARCH}"
28COMPATIBLE_MACHINE = "(mx6)" 14COMPATIBLE_MACHINE = "(mx6)"