summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2014-02-06 17:04:15 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2014-02-06 18:19:14 -0200
commit16a0399ae0ed4dba17b422d2f08a44d222a2d205 (patch)
treed4fd920ed39a2e8bf1ed6d93d21dad3200520411 /recipes-multimedia
parentd98b0608d424c912250c2e211dba5b7efd5dc54d (diff)
downloadmeta-fsl-arm-16a0399ae0ed4dba17b422d2f08a44d222a2d205.tar.gz
gstreamer1.0-imx: Add GStreamer 1.0 plugins
gstreamer-imx is an ongoing project to write GStreamer 1.0 plugins for using the i.MX VPU,IPU, and GPU. With the plugins, the VPU en- and decoding features can be used, the IPU can transform images (deinterlacing, colorspace conversion etc.), and the GPU can display frames using OpenGL ES and the Vivante direct textures. Currently, the plugins have only been tested with the i.MX6 SoC series. All plugins are based on appropriate GStreamer base classes. Physical memory metadata structures make it possible to avoid costly frame copies, making it possible to use transcoding chains that do not involve CPU copies for example. This recipe is sent to meta-fsl-arm to make these plugins more visible and available to others. Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-imx_0.9.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-imx_0.9.2.bb b/recipes-multimedia/gstreamer/gstreamer1.0-imx_0.9.2.bb
new file mode 100644
index 0000000..2bbd3f9
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-imx_0.9.2.bb
@@ -0,0 +1,29 @@
1DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms"
2LICENSE = "LGPLv2+"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
4SECTION = "multimedia"
5DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base libfslvpuwrap virtual/kernel virtual/egl \
6 virtual/libgles2 ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}"
7
8SRCBRANCH ?= "master"
9SRCREV = "331f268b3bc282351b82c3548e703ea04be72b2c"
10SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}"
11
12S = "${WORKDIR}/git"
13
14inherit waf
15
16CFLAGS += "-I${STAGING_KERNEL_DIR}/include"
17
18# configure the eglvivsink element to use the appropiate EGL platform code
19EGLVIVSINK_PLATFORM = "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', 'fb', d)}"
20EXTRA_OECONF = "--egl-platform=${EGLVIVSINK_PLATFORM}"
21
22# LIBV is used by gst-plugins-package.inc to specify the GStreamer version (0.10 vs 1.0)
23LIBV = "1.0"
24require recipes-multimedia/gstreamer/gst-plugins-package.inc
25
26# the following line is required to produce one package for each plugin
27PACKAGES_DYNAMIC = "^${PN}-.*"
28
29COMPATIBLE_MACHINE = "(mx6)"