summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2013-11-06 14:12:30 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2013-11-07 11:03:39 -0200
commit13587cefb1f9051b0fdf0e766d8129c021938231 (patch)
tree8707d5bd476422a89a882051a3df7780d598498c /recipes-multimedia/gstreamer
parent9135a32b50800cac2c3feb0bac1f19c3d6743add (diff)
downloadmeta-fsl-arm-13587cefb1f9051b0fdf0e766d8129c021938231.tar.gz
gst-fsl-plugin, gst-plugins-base: Move to gstreamer subdir
There're no reason to keep the directories split and we follow now how done in OE-Core and Meta-OE putting it inside recipes-multimedia/gstreamer/. Change-Id: Ib6e6ba20880434d500334b6f4d2f48f367c773aa Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/gstreamer')
-rw-r--r--recipes-multimedia/gstreamer/gst-fsl-plugin.inc63
-rw-r--r--recipes-multimedia/gstreamer/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch40
-rw-r--r--recipes-multimedia/gstreamer/gst-fsl-plugin_3.0.9.bb15
-rw-r--r--recipes-multimedia/gstreamer/gst-plugins-base/gstplaybin2-rawvideo-support.patch28
-rw-r--r--recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend12
5 files changed, 158 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gst-fsl-plugin.inc b/recipes-multimedia/gstreamer/gst-fsl-plugin.inc
new file mode 100644
index 0000000..e179c76
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gst-fsl-plugin.inc
@@ -0,0 +1,63 @@
1# Copyright (C) 2011-2013 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Gstreamer freescale plugins"
5LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1"
6SECTION = "multimedia"
7
8DEPENDS = "gstreamer gst-plugins-base libfslcodec libfslparser virtual/kernel"
9DEPENDS_append_mx5 = " imx-lib imx-vpu"
10DEPENDS_append_mx6 = " imx-lib imx-vpu libfslvpuwrap"
11DEPENDS_append_mx6sl = " imx-lib"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
14 file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
15 file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
16
17S = "${WORKDIR}/gst-fsl-plugins-${PV}"
18
19SRC_URI = "${FSL_MIRROR}/gst-fsl-plugins-${PV}.tar.gz"
20
21inherit autotools pkgconfig
22
23PLATFORM_mx5 = "MX51"
24PLATFORM_mx6 = "MX6"
25PLATFORM_mx6sl = "MX6SL"
26PLATFORM_mx28 = "MX28"
27
28# Todo add a mechanism to map posible build targets
29INCLUDE_DIR = "-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include"
30EXTRA_OEMAKE = "INCLUDES="${INCLUDE_DIR}""
31EXTRA_OECONF = "PLATFORM=${PLATFORM} --disable-valgrind --disable-examples --disable-debug CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR}"
32CACHED_CONFIGUREVARS += "CROSS_ROOT=${STAGING_DIR_TARGET}"
33
34PACKAGES += "${PN}-libmfwsconf ${PN}-libgplaycore ${PN}-libgstfsl \
35 ${PN}-libme ${PN}-libgstbufmeta ${PN}-libmfwba \
36 ${PN}-libfwvss ${PN}-gplay"
37
38# FIXME: Add all features
39# feature from excluded mm packages
40PACKAGECONFIG[ac3] += "--enable-ac3dec,--disable-ac3dec,libfslac3codec,libfslac3codec"
41# feature from special mm packages
42PACKAGECONFIG[aacp] += "--enable-aacpdec,--disable-aacpdec,libfslaacpcodec,libfslaacpcodec"
43MSDEPENDS = "libfslmsparser libfslmscodec"
44PACKAGECONFIG[wma10dec] +="--enable-wma10dec,--disable-wma10dec,${MSDEPENDS},${MSDEPENDS}"
45PACKAGECONFIG[wma8enc] +="--enable-wma8enc,--disable-wma8enc,${MSDEPENDS},${MSDEPENDS}"
46PACKAGECONFIG[wmv9mpdec] +="--enable-wmv9mpdec,--disable-wmv9mpdec,${MSDEPENDS},${MSDEPENDS}"
47PACKAGECONFIG[wmv78dec] +="--enable-wmv78dec,--disable-wmv78dec,${MSDEPENDS},${MSDEPENDS}"
48
49FILES_${PN} = "${libdir}/gstreamer-0.10/*.so ${datadir}"
50RDEPENDS_${PN} += "gst-plugins-good-id3demux libfslparser"
51
52FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
53FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/pkgconfig/*.pc"
54FILES_${PN}-staticdev += "${libdir}/gstreamer-0.10/*.a"
55
56FILES_${PN}-gplay = "${bindir}/gplay"
57FILES_${PN}-libmfwsconf = "${libdir}/libmfwsconf${SOLIBS}"
58FILES_${PN}-libgplaycore = "${libdir}/libgplaycore${SOLIBS}"
59FILES_${PN}-libgstfsl = "${libdir}/libgstfsl-0.10${SOLIBS}"
60FILES_${PN}-libme = "${libdir}/libme${SOLIBS}"
61FILES_${PN}-libgstbufmeta = "${libdir}/libgstbufmeta${SOLIBS}"
62FILES_${PN}-libmfwba = "${libdir}/libmfwba${SOLIBS}"
63FILES_${PN}-libfwvss = "${libdir}/libmfwvss${SOLIBS}"
diff --git a/recipes-multimedia/gstreamer/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch b/recipes-multimedia/gstreamer/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch
new file mode 100644
index 0000000..e06a250
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch
@@ -0,0 +1,40 @@
1From 28ad25933dc51d8af13927a9943a353677c31a3a Mon Sep 17 00:00:00 2001
2From: Lyon Wang <lyon.wang@freescale.com>
3Date: Tue, 22 Oct 2013 16:15:43 +0800
4Subject: [PATCH] remove GST_INFO in mfw_gst_utils.h
5
6GST_INFO() should not be used in the global header
7or it will cause some macro definiation error.
8
9so comment the GST_INFO() in the mfw_gst_utils.h
10
11Upstream-Status: Backport [GIT]
12---
13 inc/plugin/mfw_gst_utils.h | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/inc/plugin/mfw_gst_utils.h b/inc/plugin/mfw_gst_utils.h
17index 366d50e..c1b6f90 100755
18--- a/inc/plugin/mfw_gst_utils.h
19+++ b/inc/plugin/mfw_gst_utils.h
20@@ -876,7 +876,7 @@ getChipCodeFromSocid (void)
21 }
22 fclose(fp);
23
24- GST_INFO("SOC is %s\n", soc_name);
25+ //GST_INFO("SOC is %s\n", soc_name);
26
27 int num = sizeof(soc_info) / sizeof(SOC_INFO);
28 int i;
29@@ -913,7 +913,7 @@ getChipCode (void)
30 }
31
32 kv = ((kv_major << 16) + (kv_minor << 8) + kv_rel);
33- GST_INFO("kernel:%s, %d.%d.%d\n", sys_name.release, kv_major, kv_minor, kv_rel);
34+ //GST_INFO("kernel:%s, %d.%d.%d\n", sys_name.release, kv_major, kv_minor, kv_rel);
35
36 if (kv < KERN_VER(3, 10, 0))
37 return getChipCodeFromCpuinfo();
38--
391.7.9.5
40
diff --git a/recipes-multimedia/gstreamer/gst-fsl-plugin_3.0.9.bb b/recipes-multimedia/gstreamer/gst-fsl-plugin_3.0.9.bb
new file mode 100644
index 0000000..52813a5
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gst-fsl-plugin_3.0.9.bb
@@ -0,0 +1,15 @@
1# Copyright (C) 2013 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4require gst-fsl-plugin.inc
5
6# FIXME: Inspecting the source code the content is in fact 3.0.9
7SRC_URI = "${FSL_MIRROR}/gst-fsl-plugins-3.10.9-1.0.0.tar.gz \
8 file://remove-GST_INFO-in-mfw_gst_utils.h.patch"
9
10SRC_URI[md5sum] = "a338a5c25225c765ae5f44af82fe7413"
11SRC_URI[sha256sum] = "e809daa0cd60381f05a79f34a53305a5ee53bfed22192a1cda6d998acc84a6fd"
12
13S = "${WORKDIR}/gst-fsl-plugins-3.10.9-1.0.0"
14
15COMPATIBLE_MACHINE = "(mx28|mx5|mx6)"
diff --git a/recipes-multimedia/gstreamer/gst-plugins-base/gstplaybin2-rawvideo-support.patch b/recipes-multimedia/gstreamer/gst-plugins-base/gstplaybin2-rawvideo-support.patch
new file mode 100644
index 0000000..16d89b3
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gst-plugins-base/gstplaybin2-rawvideo-support.patch
@@ -0,0 +1,28 @@
1From cecba1668bc8607112a6a2b802c82b6313a0d2b4 Mon Sep 17 00:00:00 2001
2From: Adrian Alonso <aalonso@freescale.com>
3Date: Tue, 19 Jun 2012 15:37:56 -0500
4Subject: [PATCH] gstplaybin2: rawvideo support
5
6* Enable support for rawvideo
7* Support direct rendering for mfw_v4lsink plugin
8
9Signed-off-by: Adrian Alonso <aalonso@freescale.com>
10---
11 gst/playback/gstplaybin2.c | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/gst/playback/gstplaybin2.c b/gst/playback/gstplaybin2.c
15index e01ff6c..9c638ae 100644
16--- a/gst/playback/gstplaybin2.c
17+++ b/gst/playback/gstplaybin2.c
18@@ -456,7 +456,7 @@ struct _GstPlayBinClass
19 #define DEFAULT_SUBURI NULL
20 #define DEFAULT_SOURCE NULL
21 #define DEFAULT_FLAGS GST_PLAY_FLAG_AUDIO | GST_PLAY_FLAG_VIDEO | GST_PLAY_FLAG_TEXT | \
22- GST_PLAY_FLAG_SOFT_VOLUME
23+ GST_PLAY_FLAG_SOFT_VOLUME | GST_PLAY_FLAG_NATIVE_VIDEO
24 #define DEFAULT_N_VIDEO 0
25 #define DEFAULT_CURRENT_VIDEO -1
26 #define DEFAULT_N_AUDIO 0
27--
281.7.10.2
diff --git a/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend b/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend
new file mode 100644
index 0000000..3da2507
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gst-plugins-base_0.10.36.bbappend
@@ -0,0 +1,12 @@
1# Freescale gstplaybin2 rawvideo support
2
3FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
4PRINC := "${@int(PRINC) + 1}"
5
6SRC_URI_append_mxs = " file://gstplaybin2-rawvideo-support.patch"
7SRC_URI_append_mx5 = " file://gstplaybin2-rawvideo-support.patch"
8SRC_URI_append_mx6 = " file://gstplaybin2-rawvideo-support.patch"
9
10PACKAGE_ARCH_mxs = "${MACHINE_SOCARCH}"
11PACKAGE_ARCH_mx5 = "${MACHINE_SOCARCH}"
12PACKAGE_ARCH_mx6 = "${MACHINE_SOCARCH}"