summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.8.bb
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2014-09-05 23:31:36 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2014-09-15 11:16:53 -0300
commit6b6960132a7181a99931b7c4bb754e3f2d977e03 (patch)
treeb9c5c467de6b8229b6c17f629b524eda3e0345d4 /recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.8.bb
parentb4c85efb85d80b387ed4497fbfd0fdb557f0785d (diff)
downloadmeta-fsl-arm-6b6960132a7181a99931b7c4bb754e3f2d977e03.tar.gz
gstreamer1.0-plugins-imx: Update to version 0.9.8
Changes: - Fixed imxipuvideotransform's passthrough mode to make it work with playbin's about-to-finish signal - Display scale updates in imxeglvivsink weren't being handled properly - Updates to make imxv4l2src buffers shareable - Extra calls to make imxv4l2src work for TV capture - Better zero-copy support in tee'd pipelines - New IDR interval property in h264 encoder - New slice size, and intra refresh properties in encoders - Configurable framebuffer number in IPU sink - Workaround for GStreamer 1.4.0 bug related to the GST_BUFFER_FLAG_TAG_MEMORY buffer flag - Unset GST_BUFFER_FLAG_TAG_MEMORY explicitely in VPU decoder to prevent unnecessary copies - Drain decoder when a new format is set, allowing for seamless transitions - Fixed decoder shutdown freeze - Fixed leaked socket pair problem in imxeglvivsink Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.8.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.8.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.8.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.8.bb
new file mode 100644
index 0000000..ca8cc00
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.8.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms"
2LICENSE = "LGPLv2+"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
4SECTION = "multimedia"
5DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base libfslvpuwrap virtual/kernel virtual/egl \
6 virtual/libgles2 ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}"
7
8SRCBRANCH ?= "master"
9SRCREV = "4b4b9a8bb024953216fdf784bcb3220e9664d5da"
10SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}"
11
12S = "${WORKDIR}/git"
13
14inherit waf
15
16# configure the eglvivsink element to use the appropriate EGL platform code
17# X11 if x11 is present in DISTRO_FEATURES
18# Wayland if x11 is not present in DISTRO_FEATURES, but wayland is
19# Framebuffer otherwise
20EGLVIVSINK_PLATFORM = "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', \
21 base_contains('DISTRO_FEATURES', 'wayland', 'wayland', \
22 'fb', d),d)}"
23
24EXTRA_OECONF = "--egl-platform=${EGLVIVSINK_PLATFORM} --kernel-headers=${STAGING_KERNEL_DIR}/include"
25
26# LIBV is used by gst-plugins-package.inc to specify the GStreamer version (0.10 vs 1.0)
27LIBV = "1.0"
28require recipes-multimedia/gstreamer/gst-plugins-package.inc
29
30# the following line is required to produce one package for each plugin
31PACKAGES_DYNAMIC = "^${PN}-.*"
32
33COMPATIBLE_MACHINE = "(mx6)"