summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.7.bb
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2014-07-02 01:52:00 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2014-08-05 17:17:40 -0300
commitb5b85bf9bd77cc6353e48f3741422affab43f731 (patch)
treeac72bb4a89ed8140abfbaa841896478799460cb5 /recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.7.bb
parentea4de4ac28cf0f91faee99074a795ced2c8cd1dc (diff)
downloadmeta-fsl-arm-b5b85bf9bd77cc6353e48f3741422affab43f731.tar.gz
gstreamer1.0-plugins-imx: Update to version 0.9.7
Changes: - Support newer Vivante drivers, which use a different name for the direct textures extension - Sync points for forced keyframes during encoding were missing - Added checks for cases where physical memory allocators fail Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.7.bb')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.7.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.7.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.7.bb
new file mode 100644
index 0000000..a3d982e
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.9.7.bb
@@ -0,0 +1,33 @@
1DESCRIPTION = "GStreamer 1.0 plugins for i.MX platforms"
2LICENSE = "LGPLv2+"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=55ca817ccb7d5b5b66355690e9abc605"
4SECTION = "multimedia"
5DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base libfslvpuwrap virtual/kernel virtual/egl \
6 virtual/libgles2 ${@base_contains('DISTRO_FEATURES', 'x11', 'virtual/libx11', '', d)}"
7
8SRCBRANCH ?= "master"
9SRCREV = "c25d1089a3aa630cd50646fe46eb78787466a062"
10SRC_URI = "git://github.com/Freescale/gstreamer-imx.git;branch=${SRCBRANCH}"
11
12S = "${WORKDIR}/git"
13
14inherit waf
15
16# configure the eglvivsink element to use the appropiate EGL platform code
17# X11 if x11 is present in DISTRO_FEATURES
18# Wayland if x11 is not present in DISTRO_FEATURES, but wayland is
19# Framebuffer otherwise
20EGLVIVSINK_PLATFORM = "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', \
21 base_contains('DISTRO_FEATURES', 'wayland', 'wayland', \
22 'fb', d),d)}"
23
24EXTRA_OECONF = "--egl-platform=${EGLVIVSINK_PLATFORM} --kernel-headers=${STAGING_KERNEL_DIR}/include"
25
26# LIBV is used by gst-plugins-package.inc to specify the GStreamer version (0.10 vs 1.0)
27LIBV = "1.0"
28require recipes-multimedia/gstreamer/gst-plugins-package.inc
29
30# the following line is required to produce one package for each plugin
31PACKAGES_DYNAMIC = "^${PN}-.*"
32
33COMPATIBLE_MACHINE = "(mx6)"