summaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/gst-plugins
diff options
context:
space:
mode:
authorAdrian Alonso <b38018@freescale.com>2011-08-24 18:01:59 -0500
committerAdrian Alonso <b38018@freescale.com>2011-08-24 18:01:59 -0500
commit6c66c6c1d3000974bd85935fdea5a1490fca86ce (patch)
treeeaddfe9cf7f253ed63d4a770fe29ee7c3f767541 /recipes-multimedia/gst-plugins
parentb8c4665ee315914bead1bee9c27099eb6101c73d (diff)
downloadmeta-fsl-arm-6c66c6c1d3000974bd85935fdea5a1490fca86ce.tar.gz
gst-fsl-plugin: gstreamer freescale plugins
* Gstreamer Freescale plugins, builds by default plugins for imx53 targets. * Need a mechanism to override build platform settings. Signed-off-by: Adrian Alonso <b38018@freescale.com>
Diffstat (limited to 'recipes-multimedia/gst-plugins')
-rw-r--r--recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.1.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.1.bb b/recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.1.bb
new file mode 100644
index 0000000..177113b
--- /dev/null
+++ b/recipes-multimedia/gst-plugins/gst-fsl-plugin_2.0.1.bb
@@ -0,0 +1,25 @@
1# Copyright (C) 2011 Freescale Semicondutor
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4inherit autotools pkgconfig
5
6DESCRIPTION = "Gstreamer freescale plugins"
7LICENSE = "GPLv2 & LGPLv2 & LGPLv2.1"
8SECTION = "multimedia"
9DEPENDS = "gstreamer fsl-mm-codeclib imx-lib"
10PR = "r0"
11
12LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
13 file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
14 file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24"
15
16SRC_URI = "http://auslxsc01.mtwk.freescale.net/ppp/${PN}-${PV}.tar.gz"
17SRC_URI[md5sum] = "ef414365901a4457d8c091615c0749e0"
18SRC_URI[sha256sum] = "99668788886d7a9223c5cc2a408631d6fbf9094894da34c6c00036a9fe1253de"
19
20# Todo add a mechanism to map posible build targets
21EXTRA_OECONF = "PLATFORM=MX53 --disable-valgrind --disable-examples"
22
23FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
24FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
25FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"