summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-08-18 20:37:22 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-09-18 16:09:52 -0300
commiteb325bf5b4fcf92b6e509f521754c17449880298 (patch)
treeeda052cc78f6f25d15fdffc7baab9b4805b05fc3 /recipes-kernel
parent32cf391ada5ce1e9d16c2332eb0dbb9413e41258 (diff)
downloadmeta-fsl-arm-eb325bf5b4fcf92b6e509f521754c17449880298.tar.gz
kernel-module-imx-gpu-viv: Fix build against 3.14-based kernels
The build fail about the bus frequency header (linux/busfreq-imx6.h) not being found is caused by the mistaken check for the wrong kernel version. This patch fixes it by adding the right kernel version to be checked. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/platform-Fix-kernel-version-check-for-3.14-based-ker.patch35
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p6.3.bb3
2 files changed, 37 insertions, 1 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/platform-Fix-kernel-version-check-for-3.14-based-ker.patch b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/platform-Fix-kernel-version-check-for-3.14-based-ker.patch
new file mode 100644
index 0000000..3b92ac8
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/platform-Fix-kernel-version-check-for-3.14-based-ker.patch
@@ -0,0 +1,35 @@
1From 617bdbec386a1237e2a148989318cc4a1360788a Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Tue, 18 Aug 2015 23:08:48 +0000
4Subject: [PATCH] platform: Fix kernel version check for 3.14-based kernels
5Organization: O.S. Systems Software LTDA.
6
7The build fail about the bus frequency header (linux/busfreq-imx6.h)
8not being found is caused by the mistaken check for the wrong kernel
9version.
10
11This patch fixes it by adding the right kernel version to be checked.
12
13Upstream-Status: Pending
14
15Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
16---
17 .../os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/imx-gpu-viv-kernel-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c b/imx-gpu-viv-kernel-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c
21index a2e72ff..241614a 100644
22--- a/imx-gpu-viv-kernel-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c
23+++ b/imx-gpu-viv-kernel-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c
24@@ -40,7 +40,7 @@
25 #include <linux/pm_runtime.h>
26 #if LINUX_VERSION_CODE < KERNEL_VERSION(3, 10, 0)
27 #include <mach/busfreq.h>
28-#elif LINUX_VERSION_CODE < KERNEL_VERSION(3, 14, 0)
29+#elif LINUX_VERSION_CODE < KERNEL_VERSION(3, 15, 0)
30 #include <linux/busfreq-imx6.h>
31 #include <linux/reset.h>
32 #else
33--
342.1.4
35
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p6.3.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p6.3.bb
index db9dcbb..a27decd 100644
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p6.3.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p6.3.bb
@@ -8,7 +8,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8 8
9inherit module 9inherit module
10 10
11SRC_URI = "${FSL_MIRROR}/imx-gpu-viv-kernel-${@'${PV}'.replace('5.0.11.p6.3', '5.0.11.p6.3-beta')}.tar.gz" 11SRC_URI = "${FSL_MIRROR}/imx-gpu-viv-kernel-${@'${PV}'.replace('5.0.11.p6.3', '5.0.11.p6.3-beta')}.tar.gz \
12 file://platform-Fix-kernel-version-check-for-3.14-based-ker.patch"
12 13
13SRC_URI[md5sum] = "6d46da80de94e98ee68ab1a75f384b89" 14SRC_URI[md5sum] = "6d46da80de94e98ee68ab1a75f384b89"
14SRC_URI[sha256sum] = "e4b02fc0c9bdbfc7ecc67a0bad0917e788921c8f2444d99bd77daae7f3cd95df" 15SRC_URI[sha256sum] = "e4b02fc0c9bdbfc7ecc67a0bad0917e788921c8f2444d99bd77daae7f3cd95df"