summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-09-22 19:20:04 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-09-22 19:22:32 -0300
commit4e44a7efab9259b6e4536b549b374f5550769d4c (patch)
tree91906279d6938dc6aca6578ebeaa4e5d2c3d2f31 /recipes-kernel
parent8cbf07b4cb022ef90140d18aaefabf01c4d45331 (diff)
downloadmeta-fsl-arm-4e44a7efab9259b6e4536b549b374f5550769d4c.tar.gz
kernel-module-imx-gpu-viv: Fix build against 3.14-based kernels - again
The build fail about the bus frequency header (linux/busfreq-imx6.h) not being found is caused by the mistaken check for the wrong kernel version. The regression has been introduced by d476c35 (kernel-module-imx-gpu-viv: Upgrade to 5.0.11.p7.1 for 3.14.38-6QP_ga release) which has been not properly tested. This patch fixes it, again, by adding back the removed patch. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/platform-Fix-kernel-version-check-for-3.14-based-ker.patch35
-rw-r--r--recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p7.1.bb2
2 files changed, 36 insertions, 1 deletions
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/platform-Fix-kernel-version-check-for-3.14-based-ker.patch b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/platform-Fix-kernel-version-check-for-3.14-based-ker.patch
new file mode 100644
index 0000000..3dc0617
--- /dev/null
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv/platform-Fix-kernel-version-check-for-3.14-based-ker.patch
@@ -0,0 +1,35 @@
1From 617bdbec386a1237e2a148989318cc4a1360788a Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Tue, 18 Aug 2015 23:08:48 +0000
4Subject: [PATCH] platform: Fix kernel version check for 3.14-based kernels
5Organization: O.S. Systems Software LTDA.
6
7The build fail about the bus frequency header (linux/busfreq-imx6.h)
8not being found is caused by the mistaken check for the wrong kernel
9version.
10
11This patch fixes it by adding the right kernel version to be checked.
12
13Upstream-Status: Pending
14
15Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
16---
17 .../os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c b/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c
21index a2e72ff..241614a 100644
22--- a/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c
23+++ b/kernel-module-imx-gpu-viv-src/hal/os/linux/kernel/platform/freescale/gc_hal_kernel_platform_imx6q14.c
24@@ -40,7 +40,7 @@
25 #include <linux/pm_runtime.h>
26 #if LINUX_VERSION_CODE < KERNEL_VERSION(3, 10, 0)
27 #include <mach/busfreq.h>
28-#elif LINUX_VERSION_CODE < KERNEL_VERSION(3, 14, 0)
29+#elif LINUX_VERSION_CODE < KERNEL_VERSION(3, 15, 0)
30 #include <linux/busfreq-imx6.h>
31 #include <linux/reset.h>
32 #else
33--
342.1.4
35
diff --git a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p7.1.bb b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p7.1.bb
index 8d316ff..3218b4e 100644
--- a/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p7.1.bb
+++ b/recipes-kernel/kernel-modules/kernel-module-imx-gpu-viv_5.0.11.p7.1.bb
@@ -10,7 +10,7 @@ inherit module
10 10
11SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.tar.gz \ 11SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.tar.gz \
12 file://updatemakefile.patch \ 12 file://updatemakefile.patch \
13 " 13 file://platform-Fix-kernel-version-check-for-3.14-based-ker.patch"
14 14
15SRC_URI[md5sum] = "a251a94390986371f75b338ad938e46f" 15SRC_URI[md5sum] = "a251a94390986371f75b338ad938e46f"
16SRC_URI[sha256sum] = "9aaef0a62bc2be69dc568228192b060c54970b5c700fee602d83a4d13e04a9b3" 16SRC_URI[sha256sum] = "9aaef0a62bc2be69dc568228192b060c54970b5c700fee602d83a4d13e04a9b3"