summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorGary Bisson <bisson.gary@gmail.com>2014-12-03 18:23:56 -0800
committerOtavio Salvador <otavio@ossystems.com.br>2014-12-04 09:16:09 -0200
commitf8b9c3024fe5621cf1a99832c37b8bf74d80853b (patch)
tree1873d6a07ad1ff160c275880cde9b35f56dc8a83 /recipes-kernel
parent9f2bbbdf3ca2ef50c33ae5614eea663d777ed6f3 (diff)
downloadmeta-fsl-arm-f8b9c3024fe5621cf1a99832c37b8bf74d80853b.tar.gz
linux-imx: add clock patch for revision T0 1.0 of i.MX6Q
The post dividers do not work on i.MX6Q rev T0 1.0 so they must be fixed to 1. As the table index was wrong, a divider a of 4 could still be requested which implied the clock not to be set properly. This is the root cause of the HDMI not working at high resolution on rev T0 1.0 of the SoC, giving the following error: mxc_sdc_fb fb.27: timeout when waiting for flip irq Signed-off-by: Gary Bisson <bisson.gary@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-imx-3.10.31/0001-ARM-clk-imx6q-fix-video-divider-for-revision-1.0-of-.patch35
-rw-r--r--recipes-kernel/linux/linux-imx_3.10.31.bb2
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx-3.10.31/0001-ARM-clk-imx6q-fix-video-divider-for-revision-1.0-of-.patch b/recipes-kernel/linux/linux-imx-3.10.31/0001-ARM-clk-imx6q-fix-video-divider-for-revision-1.0-of-.patch
new file mode 100644
index 0000000..820ce68
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-3.10.31/0001-ARM-clk-imx6q-fix-video-divider-for-revision-1.0-of-.patch
@@ -0,0 +1,35 @@
1From 0e981452d7130513e796c1c3d7348905c0d00dce Mon Sep 17 00:00:00 2001
2From: Gary Bisson <bisson.gary@gmail.com>
3Date: Tue, 2 Dec 2014 22:11:14 -0800
4Subject: [PATCH] ARM: clk-imx6q: fix video divider for revision 1.0 of i.MX6q
5
6As post dividers do not work on i.MX6Q revision 1.0 they must be fixed
7to 1. As the table index was wrong, a divider a of 4 could still be
8requested which implied the clock not to be set properly. This is the
9root cause of the HDMI not working at high resolution on T1.0 version of
10the SoC, giving the following error:
11mxc_sdc_fb fb.27: timeout when waiting for flip irq
12
13Upstream-Status: Pending
14
15Signed-off-by: Gary Bisson <bisson.gary@gmail.com>
16---
17 arch/arm/mach-imx/clk-imx6q.c | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/arch/arm/mach-imx/clk-imx6q.c b/arch/arm/mach-imx/clk-imx6q.c
21index 25734ed..34e1616f 100644
22--- a/arch/arm/mach-imx/clk-imx6q.c
23+++ b/arch/arm/mach-imx/clk-imx6q.c
24@@ -312,7 +312,7 @@ static void __init imx6q_clocks_init(struct device_node *ccm_node)
25 post_div_table[1].div = 1;
26 post_div_table[2].div = 1;
27 video_div_table[1].div = 1;
28- video_div_table[2].div = 1;
29+ video_div_table[3].div = 1;
30 };
31
32 /* type name parent_name base div_mask */
33--
342.1.3
35
diff --git a/recipes-kernel/linux/linux-imx_3.10.31.bb b/recipes-kernel/linux/linux-imx_3.10.31.bb
index 10ad2f0..8084096 100644
--- a/recipes-kernel/linux/linux-imx_3.10.31.bb
+++ b/recipes-kernel/linux/linux-imx_3.10.31.bb
@@ -14,4 +14,6 @@ SRCBRANCH = "imx_3.10.31_1.1.0_beta"
14SRCREV = "94a7e472c47b800c001c0a5d17bb2f14a13e1980" 14SRCREV = "94a7e472c47b800c001c0a5d17bb2f14a13e1980"
15LOCALVERSION = "-1.1.0_beta" 15LOCALVERSION = "-1.1.0_beta"
16 16
17SRC_URI += "file://0001-ARM-clk-imx6q-fix-video-divider-for-revision-1.0-of-.patch"
18
17COMPATIBLE_MACHINE = "(mx6)" 19COMPATIBLE_MACHINE = "(mx6)"