summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorMario Domenech Goulart <mario@ossystems.com.br>2014-04-03 15:52:45 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2014-04-04 10:09:46 -0300
commit24420bf535cd5a2201ac21c0f379d7f9bf31968c (patch)
treee130cb1e6f55e65e23b5738aaefec5d7f5ee502c /recipes-kernel
parente76f0312f85f8bf8a44760ae4afe13e918675253 (diff)
downloadmeta-fsl-arm-24420bf535cd5a2201ac21c0f379d7f9bf31968c.tar.gz
linux-imx.inc: move SUMMARY and DESCRIPTION from .inc to .bb's
SUMMARY and DESCRIPTION should really go into recipes (.bb). Setting SUMMARY and DESCRIPTION in include files can easily cause recipes' to be clobbered by the ones set in included files, since they are usually set before including common files. A typical example: $ cat some-common-file.inc DESCRIPTION = "I'll clobber your description" $ cat some-recipe.bb DESCRIPTION = "I'll get clobbered" include some-common-file.inc Another problematic case is with regard to recipes that include multiple common files that set SUMMARY and DESCRIPTION (the last included ones will clobber the previous ones). That's actually the expected behavior when we include files, but it's slightly surprising in case of variables like SUMMARY and DESCRIPTION, which usually are the first ones defined in recipe files (before `include'). Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-imx.inc3
-rw-r--r--recipes-kernel/linux/linux-imx_2.6.35.3.bb4
-rw-r--r--recipes-kernel/linux/linux-imx_3.10.17.bb4
3 files changed, 8 insertions, 3 deletions
diff --git a/recipes-kernel/linux/linux-imx.inc b/recipes-kernel/linux/linux-imx.inc
index f1f89b2..47566b0 100644
--- a/recipes-kernel/linux/linux-imx.inc
+++ b/recipes-kernel/linux/linux-imx.inc
@@ -1,9 +1,6 @@
1# Copyright (C) 2012, 2014 O.S. Systems Software LTDA. 1# Copyright (C) 2012, 2014 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3 3
4SUMMARY = "Linux Kernel provided and supported by Freescale"
5DESCRIPTION = "Linux Kernel provided and supported by Freescale with focus on \
6i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU and IPU."
7LICENSE = "GPLv2" 4LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7" 5LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
9 6
diff --git a/recipes-kernel/linux/linux-imx_2.6.35.3.bb b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
index f42c2c2..be39179 100644
--- a/recipes-kernel/linux/linux-imx_2.6.35.3.bb
+++ b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
@@ -1,6 +1,10 @@
1# Copyright (C) 2011-2013 Freescale Semiconductor 1# Copyright (C) 2011-2013 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3 3
4SUMMARY = "Linux Kernel provided and supported by Freescale"
5DESCRIPTION = "Linux Kernel provided and supported by Freescale with focus on \
6i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU and IPU."
7
4PR = "r45" 8PR = "r45"
5 9
6include linux-imx.inc 10include linux-imx.inc
diff --git a/recipes-kernel/linux/linux-imx_3.10.17.bb b/recipes-kernel/linux/linux-imx_3.10.17.bb
index 03f8f7a..f9a2969 100644
--- a/recipes-kernel/linux/linux-imx_3.10.17.bb
+++ b/recipes-kernel/linux/linux-imx_3.10.17.bb
@@ -1,6 +1,10 @@
1# Copyright (C) 2013, 2014 Freescale Semiconductor 1# Copyright (C) 2013, 2014 Freescale Semiconductor
2# Released under the MIT license (see COPYING.MIT for the terms) 2# Released under the MIT license (see COPYING.MIT for the terms)
3 3
4SUMMARY = "Linux Kernel provided and supported by Freescale"
5DESCRIPTION = "Linux Kernel provided and supported by Freescale with focus on \
6i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU and IPU."
7
4require recipes-kernel/linux/linux-imx.inc 8require recipes-kernel/linux/linux-imx.inc
5require recipes-kernel/linux/linux-dtb.inc 9require recipes-kernel/linux/linux-dtb.inc
6 10