summaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
authorGary Bisson <bisson.gary@gmail.com>2014-12-03 15:10:11 -0800
committerOtavio Salvador <otavio@ossystems.com.br>2014-12-03 21:14:45 -0200
commit2376d3d7c898bbda9ce98f9dedcc63b19ccffd93 (patch)
treeb94085dd2035616f914283a84a1e31ab0bdd0081 /recipes-kernel
parent0dc554851cdd89aafb297ce4f4320bce39c7cda8 (diff)
downloadmeta-fsl-arm-2376d3d7c898bbda9ce98f9dedcc63b19ccffd93.tar.gz
linux-imx: add clock patch for revision T0 1.0 of i.MX6Q
The post dividers do not work on i.MX6Q rev T0 1.0 so they must be fixed to 1. As the table index was wrong, a divider a of 4 could still be requested which implied the clock not to be set properly. This is the root cause of the HDMI not working at high resolution on rev T0 1.0 of the SoC, giving the following error: mxc_sdc_fb fb.27: timeout when waiting for flip irq Signed-off-by: Gary Bisson <bisson.gary@gmail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-imx-3.10.17/0001-ARM-clk-imx6q-fix-video-divider-for-revision-1.0-of-.patch35
-rw-r--r--recipes-kernel/linux/linux-imx_3.10.17.bb2
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx-3.10.17/0001-ARM-clk-imx6q-fix-video-divider-for-revision-1.0-of-.patch b/recipes-kernel/linux/linux-imx-3.10.17/0001-ARM-clk-imx6q-fix-video-divider-for-revision-1.0-of-.patch
new file mode 100644
index 0000000..3d13b6f
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-3.10.17/0001-ARM-clk-imx6q-fix-video-divider-for-revision-1.0-of-.patch
@@ -0,0 +1,35 @@
1From ffcd8b98f6ba3a2b7a4aecc1e5e454de5fa5c4c3 Mon Sep 17 00:00:00 2001
2From: Gary Bisson <bisson.gary@gmail.com>
3Date: Tue, 2 Dec 2014 22:11:14 -0800
4Subject: [PATCH] ARM: clk-imx6q: fix video divider for revision 1.0 of i.MX6q
5
6As post dividers do not work on i.MX6Q revision 1.0 they must be fixed
7to 1. As the table index was wrong, a divider a of 4 could still be
8requested which implied the clock not to be set properly. This is the
9root cause of the HDMI not working at high resolution on T1.0 version of
10the SoC, giving the following error:
11mxc_sdc_fb fb.27: timeout when waiting for flip irq
12
13Upstream-Status: Pending
14
15Signed-off-by: Gary Bisson <bisson.gary@gmail.com>
16---
17 arch/arm/mach-imx/clk-imx6q.c | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/arch/arm/mach-imx/clk-imx6q.c b/arch/arm/mach-imx/clk-imx6q.c
21index e09b1e8..1e5c410 100644
22--- a/arch/arm/mach-imx/clk-imx6q.c
23+++ b/arch/arm/mach-imx/clk-imx6q.c
24@@ -279,7 +279,7 @@ static void __init imx6q_clocks_init(struct device_node *ccm_node)
25 post_div_table[1].div = 1;
26 post_div_table[2].div = 1;
27 video_div_table[1].div = 1;
28- video_div_table[2].div = 1;
29+ video_div_table[3].div = 1;
30 };
31
32 /* type name parent_name base div_mask */
33--
342.1.3
35
diff --git a/recipes-kernel/linux/linux-imx_3.10.17.bb b/recipes-kernel/linux/linux-imx_3.10.17.bb
index cae1489..143eaab 100644
--- a/recipes-kernel/linux/linux-imx_3.10.17.bb
+++ b/recipes-kernel/linux/linux-imx_3.10.17.bb
@@ -15,4 +15,6 @@ SRCBRANCH = "imx_3.10.17_1.0.0_ga"
15SRCREV = "33597e348b2d60dd5c71890ef7b7d3d3fd6e4e97" 15SRCREV = "33597e348b2d60dd5c71890ef7b7d3d3fd6e4e97"
16LOCALVERSION = "-1.0.2_ga" 16LOCALVERSION = "-1.0.2_ga"
17 17
18SRC_URI += "file://0001-ARM-clk-imx6q-fix-video-divider-for-revision-1.0-of-.patch"
19
18COMPATIBLE_MACHINE = "(mx6)" 20COMPATIBLE_MACHINE = "(mx6)"