summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx_3.14.28.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-06-08 14:48:05 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2015-06-10 12:10:09 -0300
commit172a4277f0632941aa74f02495d2c420e5495323 (patch)
treef2d20c286d7d05e95fe51fb4b90cc2817b8e5ece /recipes-kernel/linux/linux-imx_3.14.28.bb
parentcb3ff963b1bbff7d2c2a9e6344e4ea592a958154 (diff)
downloadmeta-fsl-arm-172a4277f0632941aa74f02495d2c420e5495323.tar.gz
linux-imx_3.14.28: fix initial MMC device detection
On Variscite Varsom we have three devices connected to MMC * MMC1: eMMC * MMC2: SDCard * MMC3: Wifi Without this patch only the first device was detected properly. I found two workarounds which can be removed by this patch: 1. Variscite: booting from SDCard made possible by renumbering MMC devices [1]. 2. BoundaryDevices: Add workqueues for each mmc_host [2]. This had been tested here too but causes crashing sdcard for huge storage traffic. [1] https://github.com/varigit/linux-2.6-imx/blob/imx_3.10.53_1.1.0_ga_var01/arch/arm/boot/dts/imx6qdl.dtsi / Line 879 [2] https://github.com/boundarydevices/linux-imx6/commit/1d40159a995a298f16901bfb14ae3e0294c65691 Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/linux/linux-imx_3.14.28.bb')
-rw-r--r--recipes-kernel/linux/linux-imx_3.14.28.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx_3.14.28.bb b/recipes-kernel/linux/linux-imx_3.14.28.bb
index e3078f7..5d1be54 100644
--- a/recipes-kernel/linux/linux-imx_3.14.28.bb
+++ b/recipes-kernel/linux/linux-imx_3.14.28.bb
@@ -18,6 +18,7 @@ SRC_URI += " \
18 file://0001-ARM-imx6q-drop-unnecessary-semicolon.patch \ 18 file://0001-ARM-imx6q-drop-unnecessary-semicolon.patch \
19 file://0002-ARM-clk-imx6q-fix-video-divider-for-rev-T0-1.0.patch \ 19 file://0002-ARM-clk-imx6q-fix-video-divider-for-rev-T0-1.0.patch \
20 file://0003-ARM-imx6sl-Disable-imx6sl-specific-code-when-imx6sl-.patch \ 20 file://0003-ARM-imx6sl-Disable-imx6sl-specific-code-when-imx6sl-.patch \
21 file://0004-mmc-sdhci-esdhc-imx-Fixup-runtime-PM-conditions-duri.patch \
21" 22"
22 23
23COMPATIBLE_MACHINE = "(mx6)" 24COMPATIBLE_MACHINE = "(mx6)"