summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx-2.6.35.3
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2012-09-09 21:42:08 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2012-09-11 15:24:14 -0300
commit07b2445d0ab036b7c63702d2527c51f1333c4de6 (patch)
tree6948a830b3c36d9307b6af1be6d6a234257972e2 /recipes-kernel/linux/linux-imx-2.6.35.3
parent961b6eb9d8638b26242348c6a5bdc8dc52e9e8ab (diff)
downloadmeta-fsl-arm-07b2445d0ab036b7c63702d2527c51f1333c4de6.tar.gz
linux-imx (2.6.35.3): perf tools: Do not treat warnings as errors
Newer GCC detect more warnings and this makes building of perf not possible in the upcoming release of Yocto (1.3). We deal with that making the warnings not fatal instead of changing perf code. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-kernel/linux/linux-imx-2.6.35.3')
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Do-not-treat-warnings-as-errors.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Do-not-treat-warnings-as-errors.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Do-not-treat-warnings-as-errors.patch
new file mode 100644
index 0000000..a22e45b
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-2.6.35.3/perf-tools-Do-not-treat-warnings-as-errors.patch
@@ -0,0 +1,30 @@
1From b4084d9ae7d8ac3d7fe01cc745836313ae73afb6 Mon Sep 17 00:00:00 2001
2From: Otavio Salvador <otavio@ossystems.com.br>
3Date: Fri, 7 Sep 2012 20:22:47 -0300
4Subject: [PATCH] perf tools: Do not treat warnings as errors
5
6Newer GCC detect more warnings and this makes building of perf not
7possible in the upcoming release of Yocto (1.3). We deal with that
8making the warnings not fatal instead of changing perf code.
9
10Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
11---
12 tools/perf/Makefile | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/tools/perf/Makefile b/tools/perf/Makefile
16index d75c28a..854652a 100644
17--- a/tools/perf/Makefile
18+++ b/tools/perf/Makefile
19@@ -225,7 +225,7 @@ ifndef PERF_DEBUG
20 CFLAGS_OPTIMIZE = -O6
21 endif
22
23-CFLAGS = -ggdb3 -Wall -Wextra -std=gnu99 -Werror $(CFLAGS_OPTIMIZE) -D_FORTIFY_SOURCE=2 $(EXTRA_WARNINGS) $(EXTRA_CFLAGS)
24+CFLAGS = -ggdb3 -Wall -Wextra -std=gnu99 $(CFLAGS_OPTIMIZE) -D_FORTIFY_SOURCE=2 $(EXTRA_WARNINGS) $(EXTRA_CFLAGS)
25 EXTLIBS = -lpthread -lrt -lelf -lm
26 ALL_CFLAGS = $(CFLAGS) -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
27 ALL_LDFLAGS = $(LDFLAGS)
28--
291.7.10.4
30