summaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2011-12-21 18:16:26 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2011-12-21 18:42:14 +0000
commite701790e088665186f3466ee8fa234cc19d7d975 (patch)
tree557dc19495164e0f104673ff8ae4c17850a9112c /recipes-graphics
parent8c39651bb6393447b325585bbec4585dbda1f182 (diff)
downloadmeta-fsl-arm-e701790e088665186f3466ee8fa234cc19d7d975.tar.gz
xserver-xf86-config: move xorg.conf to being machine specific
While on that we refactored the recipe to use PRINC and FILESEXTRAPATHS_prepend. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/imx53ard/xorg.conf (renamed from recipes-graphics/xorg-xserver/xserver-xf86-config/xorg.conf)0
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config/imx53qsb/xorg.conf45
-rw-r--r--recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend4
3 files changed, 47 insertions, 2 deletions
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/imx53ard/xorg.conf
index bbb1f53..bbb1f53 100644
--- a/recipes-graphics/xorg-xserver/xserver-xf86-config/xorg.conf
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/imx53ard/xorg.conf
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config/imx53qsb/xorg.conf b/recipes-graphics/xorg-xserver/xserver-xf86-config/imx53qsb/xorg.conf
new file mode 100644
index 0000000..bbb1f53
--- /dev/null
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config/imx53qsb/xorg.conf
@@ -0,0 +1,45 @@
1Section "InputDevice"
2 Identifier "Generic Keyboard"
3 Driver "kbd"
4 Option "XkbRules" "xorg"
5 Option "XkbModel" "pc105"
6 Option "XkbLayout" "us"
7EndSection
8
9Section "InputDevice"
10 Identifier "Configured Mouse"
11 Driver "mouse"
12 Option "CorePointer"
13EndSection
14
15Section "InputClass"
16 Identifier "eGalax"
17 MatchIsTouchscreen "on"
18 MatchDevicePath "/dev/input/event*"
19 Driver "evdev"
20EndSection
21
22Section "Device"
23 Identifier "i.MX Accelerated Framebuffer Device"
24 Driver "imx"
25 Option "fbdev" "/dev/fb0"
26 # This option only recognized when "mxc_epdc_fb" frame buffer driver in
27 # use. Values are "RGB565" (default, 16-bit RGB), "Y8" (8-bit gray),
28 # and "Y8INV" (8-bit gray inverted).
29 Option "FormatEPDC" "Y8INV"
30EndSection
31
32Section "Monitor"
33 Identifier "Configured Monitor"
34EndSection
35
36Section "Screen"
37 Identifier "Default Screen"
38 Monitor "Configured Monitor"
39 Device "i.MX Accelerated Framebuffer Device"
40EndSection
41
42Section "ServerLayout"
43 Identifier "Default Layout"
44 Screen "Default Screen"
45EndSection
diff --git a/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
index e6c5a53..56cb294 100644
--- a/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
+++ b/recipes-graphics/xorg-xserver/xserver-xf86-config_0.1.bbappend
@@ -1,4 +1,4 @@
1# Append path for freescale layer to include bsp xorg.conf 1# Append path for freescale layer to include bsp xorg.conf
2THISDIR := "${@os.path.dirname(bb.data.getVar('FILE', d, True))}" 2FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
3FILESPATH =. "${@base_set_filespath(["${THISDIR}/${PN}"], d)}:"
4 3
4PRINC := "${@int(PRINC) + 1}"