diff options
author | Eric BENARD <eric@eukrea.com> | 2013-06-03 07:57:30 +0000 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2013-06-17 10:58:52 -0300 |
commit | de9bd50c598f557aedc927e3b7690eb7a9481fb0 (patch) | |
tree | 23b6a84619125c66e78cb08ae3d689c57aceb93b /recipes-graphics | |
parent | 6776e274a7f570e7a48f0325d653dfbff22b3e47 (diff) | |
download | meta-fsl-arm-de9bd50c598f557aedc927e3b7690eb7a9481fb0.tar.gz |
amd-gpu-x11-bin-mx51: factorize the recipes
this will allow easier addition of non x11 package
Change-Id: Ib7df3aa52ae2fdc10044e475087933ea5d258b93
Signed-off-by: Eric BĂ©nard <eric@eukrea.com>
Diffstat (limited to 'recipes-graphics')
-rw-r--r-- | recipes-graphics/amd-gpu-x11-bin/amd-gpu-mx51.inc | 82 | ||||
-rw-r--r-- | recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb | 74 | ||||
-rw-r--r-- | recipes-graphics/amd-gpu-x11-bin/files/fix-linux-build-check.patch (renamed from recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51/fix-linux-build-check.patch) | 0 |
3 files changed, 83 insertions, 73 deletions
diff --git a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-mx51.inc b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-mx51.inc new file mode 100644 index 0000000..b081695 --- /dev/null +++ b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-mx51.inc | |||
@@ -0,0 +1,82 @@ | |||
1 | # Copyright (C) 2011, 2012 Freescale | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | LICENSE = "Proprietary" | ||
5 | SECTION = "libs" | ||
6 | |||
7 | # FIXME: Replace for correct AMD license | ||
8 | LIC_FILES_CHKSUM = "file://usr/include/VG/openvg.h;endline=30;md5=b0109611dd76961057d4c45ae6519802" | ||
9 | |||
10 | PROVIDES = "virtual/egl virtual/libgles1 virtual/libgles2" | ||
11 | |||
12 | SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \ | ||
13 | file://fix-linux-build-check.patch" | ||
14 | |||
15 | inherit fsl-eula-unpack | ||
16 | |||
17 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | ||
18 | # the source we cannot fix it. Disable the insane check for now. | ||
19 | python populate_packages_prepend() { | ||
20 | for p in d.getVar('PACKAGES', True).split(): | ||
21 | d.setVar("INSANE_SKIP_%s" % p, "ldflags") | ||
22 | } | ||
23 | |||
24 | do_install () { | ||
25 | install -d ${D}${libdir} | ||
26 | install -d ${D}${bindir} | ||
27 | install -d ${D}${includedir} | ||
28 | |||
29 | cp -axr ${S}/usr/bin/* ${D}${bindir} | ||
30 | cp -axf ${S}/usr/lib/* ${D}${libdir} | ||
31 | cp -axr ${S}/usr/include/* ${D}${includedir} | ||
32 | |||
33 | find ${D}${bindir} -type f -exec chmod 755 {} \; | ||
34 | find ${D}${libdir} -type f -exec chmod 644 {} \; | ||
35 | find ${D}${includedir} -type f -exec chmod 644 {} \; | ||
36 | |||
37 | # FIXME: Fix sonames of broken libraries | ||
38 | mv ${D}${libdir}/lib2dz160.so ${D}${libdir}/lib2dz160.so.0 | ||
39 | mv ${D}${libdir}/lib2dz430.so ${D}${libdir}/lib2dz430.so.0 | ||
40 | |||
41 | # FIXME: Remove unkown files | ||
42 | rm -r ${D}${libdir}/libcsi.a \ | ||
43 | ${D}${libdir}/libres.a | ||
44 | } | ||
45 | |||
46 | PACKAGES =+ "libgsl-fsl-mx51 libgsl-fsl-mx51-dev libgsl-fsl-mx51-dbg \ | ||
47 | libegl-mx51 libegl-mx51-dev libegl-mx51-dbg \ | ||
48 | libgles-mx51 libgles-mx51-dev libgles-mx51-dbg \ | ||
49 | libgles2-mx51 libgles2-mx51-dev libgles2-mx51-dbg \ | ||
50 | libopenvg-mx51 libopenvg-mx51-dev libopenvg-mx51-dbg \ | ||
51 | lib2dz160-mx51 lib2dz160-mx51-dbg \ | ||
52 | lib2dz430-mx51 lib2dz430-mx51-dbg" | ||
53 | |||
54 | FILES_${PN}-dbg = "${bindir}/.debug/*" | ||
55 | |||
56 | FILES_libgsl-fsl-mx51 = "${libdir}/libgsl-fsl${SOLIBS}" | ||
57 | FILES_libgsl-fsl-mx51-dev = "${libdir}/libgsl-fsl${SOLIBSDEV}" | ||
58 | FILES_libgsl-fsl-mx51-dbg = "${libdir}/.debug/libgsl-fsl${SOLIBS}" | ||
59 | |||
60 | FILES_libegl-mx51 = "${libdir}/libEGL${SOLIBS}" | ||
61 | FILES_libegl-mx51-dev = "${includedir}/EGL ${includedir}/KHR ${libdir}/libEGL${SOLIBSDEV}" | ||
62 | FILES_libegl-mx51-dbg = "${libdir}/.debug/libEGL${SOLIBS}" | ||
63 | |||
64 | FILES_libgles-mx51 = "${libdir}/libGLESv1*${SOLIBS}" | ||
65 | FILES_libgles-mx51-dev = "${includedir}/GLES ${libdir}/libGLESv1*${SOLIBSDEV}" | ||
66 | FILES_libgles-mx51-dbg = "${libdir}/.debug/libGLESv1*${SOLIBS}" | ||
67 | |||
68 | FILES_libgles2-mx51 = "${libdir}/libGLESv2${SOLIBS}" | ||
69 | FILES_libgles2-mx51-dev = "${includedir}/GLES2 ${libdir}/libGLESv2${SOLIBSDEV}" | ||
70 | FILES_libgles2-mx51-dbg = "${libdir}/.debug/libGLESv2${SOLIBS}" | ||
71 | |||
72 | FILES_libopenvg-mx51 = "${libdir}/libOpenVG${SOLIBS}" | ||
73 | FILES_libopenvg-mx51-dev = "${includedir}/VG ${libdir}/libOpenVG${SOLIBSDEV}" | ||
74 | FILES_libopenvg-mx51-dbg = "${libdir}/.debug/libOpenVG${SOLIBS}" | ||
75 | |||
76 | FILES_lib2dz160-mx51 = "${libdir}/lib2dz160${SOLIBS}" | ||
77 | FILES_lib2dz160-mx51-dbg = "${libdir}/.debug/lib2dz160${SOLIBS}" | ||
78 | |||
79 | FILES_lib2dz430-mx51 = "${libdir}/lib2dz430${SOLIBS}" | ||
80 | FILES_lib2dz430-mx51-dbg = "${libdir}/.debug/lib2dz430${SOLIBS}" | ||
81 | |||
82 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
diff --git a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb index 70568f9..1a3c542 100644 --- a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb +++ b/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51_11.09.01.bb | |||
@@ -2,87 +2,15 @@ | |||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
3 | 3 | ||
4 | DESCRIPTION = "GPU driver and apps for x11 on mx51" | 4 | DESCRIPTION = "GPU driver and apps for x11 on mx51" |
5 | LICENSE = "Proprietary" | ||
6 | SECTION = "libs" | ||
7 | PR = "r12" | 5 | PR = "r12" |
8 | 6 | ||
9 | # FIXME: Replace for correct AMD license | 7 | # FIXME: Replace for correct AMD license |
10 | LIC_FILES_CHKSUM = "file://usr/include/VG/openvg.h;endline=30;md5=b0109611dd76961057d4c45ae6519802" | 8 | LIC_FILES_CHKSUM = "file://usr/include/VG/openvg.h;endline=30;md5=b0109611dd76961057d4c45ae6519802" |
11 | DEPENDS = "virtual/libx11 libxrender" | 9 | DEPENDS = "virtual/libx11 libxrender" |
12 | 10 | ||
13 | PROVIDES = "virtual/egl virtual/libgles1 virtual/libgles2" | 11 | include amd-gpu-mx51.inc |
14 | 12 | ||
15 | SRC_URI = "${FSL_MIRROR}/amd-gpu-x11-bin-mx51-${PV}.bin;fsl-eula=true \ | ||
16 | file://fix-linux-build-check.patch" | ||
17 | SRC_URI[md5sum] = "54391a4e670b597d06d01253fb217cad" | 13 | SRC_URI[md5sum] = "54391a4e670b597d06d01253fb217cad" |
18 | SRC_URI[sha256sum] = "c7a6fa03b7aa2a375556c59908876554ba720c1e744baba2debb84a408f790db" | 14 | SRC_URI[sha256sum] = "c7a6fa03b7aa2a375556c59908876554ba720c1e744baba2debb84a408f790db" |
19 | 15 | ||
20 | inherit fsl-eula-unpack | ||
21 | |||
22 | # FIXME: All binaries lack GNU_HASH in elf binary but as we don't have | ||
23 | # the source we cannot fix it. Disable the insane check for now. | ||
24 | python populate_packages_prepend() { | ||
25 | for p in d.getVar('PACKAGES', True).split(): | ||
26 | d.setVar("INSANE_SKIP_%s" % p, "ldflags") | ||
27 | } | ||
28 | |||
29 | do_install () { | ||
30 | install -d ${D}${libdir} | ||
31 | install -d ${D}${bindir} | ||
32 | install -d ${D}${includedir} | ||
33 | |||
34 | cp -axr ${S}/usr/bin/* ${D}${bindir} | ||
35 | cp -axf ${S}/usr/lib/* ${D}${libdir} | ||
36 | cp -axr ${S}/usr/include/* ${D}${includedir} | ||
37 | |||
38 | find ${D}${bindir} -type f -exec chmod 755 {} \; | ||
39 | find ${D}${libdir} -type f -exec chmod 644 {} \; | ||
40 | find ${D}${includedir} -type f -exec chmod 644 {} \; | ||
41 | |||
42 | # FIXME: Fix sonames of broken libraries | ||
43 | mv ${D}${libdir}/lib2dz160.so ${D}${libdir}/lib2dz160.so.0 | ||
44 | mv ${D}${libdir}/lib2dz430.so ${D}${libdir}/lib2dz430.so.0 | ||
45 | |||
46 | # FIXME: Remove unkown files | ||
47 | rm -r ${D}${libdir}/libcsi.a \ | ||
48 | ${D}${libdir}/libres.a | ||
49 | } | ||
50 | |||
51 | PACKAGES =+ "libgsl-fsl-mx51 libgsl-fsl-mx51-dev libgsl-fsl-mx51-dbg \ | ||
52 | libegl-mx51 libegl-mx51-dev libegl-mx51-dbg \ | ||
53 | libgles-mx51 libgles-mx51-dev libgles-mx51-dbg \ | ||
54 | libgles2-mx51 libgles2-mx51-dev libgles2-mx51-dbg \ | ||
55 | libopenvg-mx51 libopenvg-mx51-dev libopenvg-mx51-dbg \ | ||
56 | lib2dz160-mx51 lib2dz160-mx51-dbg \ | ||
57 | lib2dz430-mx51 lib2dz430-mx51-dbg" | ||
58 | |||
59 | FILES_${PN}-dbg = "${bindir}/.debug/*" | ||
60 | |||
61 | FILES_libgsl-fsl-mx51 = "${libdir}/libgsl-fsl${SOLIBS}" | ||
62 | FILES_libgsl-fsl-mx51-dev = "${libdir}/libgsl-fsl${SOLIBSDEV}" | ||
63 | FILES_libgsl-fsl-mx51-dbg = "${libdir}/.debug/libgsl-fsl${SOLIBS}" | ||
64 | |||
65 | FILES_libegl-mx51 = "${libdir}/libEGL${SOLIBS}" | ||
66 | FILES_libegl-mx51-dev = "${includedir}/EGL ${includedir}/KHR ${libdir}/libEGL${SOLIBSDEV}" | ||
67 | FILES_libegl-mx51-dbg = "${libdir}/.debug/libEGL${SOLIBS}" | ||
68 | |||
69 | FILES_libgles-mx51 = "${libdir}/libGLESv1*${SOLIBS}" | ||
70 | FILES_libgles-mx51-dev = "${includedir}/GLES ${libdir}/libGLESv1*${SOLIBSDEV}" | ||
71 | FILES_libgles-mx51-dbg = "${libdir}/.debug/libGLESv1*${SOLIBS}" | ||
72 | |||
73 | FILES_libgles2-mx51 = "${libdir}/libGLESv2${SOLIBS}" | ||
74 | FILES_libgles2-mx51-dev = "${includedir}/GLES2 ${libdir}/libGLESv2${SOLIBSDEV}" | ||
75 | FILES_libgles2-mx51-dbg = "${libdir}/.debug/libGLESv2${SOLIBS}" | ||
76 | |||
77 | FILES_libopenvg-mx51 = "${libdir}/libOpenVG${SOLIBS}" | ||
78 | FILES_libopenvg-mx51-dev = "${includedir}/VG ${libdir}/libOpenVG${SOLIBSDEV}" | ||
79 | FILES_libopenvg-mx51-dbg = "${libdir}/.debug/libOpenVG${SOLIBS}" | ||
80 | |||
81 | FILES_lib2dz160-mx51 = "${libdir}/lib2dz160${SOLIBS}" | ||
82 | FILES_lib2dz160-mx51-dbg = "${libdir}/.debug/lib2dz160${SOLIBS}" | ||
83 | |||
84 | FILES_lib2dz430-mx51 = "${libdir}/lib2dz430${SOLIBS}" | ||
85 | FILES_lib2dz430-mx51-dbg = "${libdir}/.debug/lib2dz430${SOLIBS}" | ||
86 | |||
87 | COMPATIBLE_MACHINE = "${@base_contains('DISTRO_FEATURES', 'x11', '(mx5)', 'Invalid!', d)}" | 16 | COMPATIBLE_MACHINE = "${@base_contains('DISTRO_FEATURES', 'x11', '(mx5)', 'Invalid!', d)}" |
88 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
diff --git a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51/fix-linux-build-check.patch b/recipes-graphics/amd-gpu-x11-bin/files/fix-linux-build-check.patch index 946bfac..946bfac 100644 --- a/recipes-graphics/amd-gpu-x11-bin/amd-gpu-x11-bin-mx51/fix-linux-build-check.patch +++ b/recipes-graphics/amd-gpu-x11-bin/files/fix-linux-build-check.patch | |||